Skip to content

← Actionable
High, CVSS 7.5amended

PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments

CVE-2026-45623GHSA-6g55-p6wh-862q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (postcss 8.5.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm postcss

    Affected
    <= 8.5.11
    Fixed in
    8.5.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-45623: 0.61% estimated exploitation activity in the next 30 days; percentile 49.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PostCSS's PreviousMap parses the /

sourceMappingURL=PATH / comment from any CSS string passed to process() and dereferences PATH against the local filesystem with no scheme, allowlist, or traversal check. An attacker who controls the CSS input can cause the host process to read any file readable by Node and leak the first ~10 bytes of its content through the resulting JSON.parse SyntaxError message. The bug also yields a precise file-existence oracle and a controllable-read primitive that may be combined with large-file targets for DoS. The behaviour is triggered with PostCSS's default options — no from, no map, no plugins required — and is therefore reachable from any pipeline that runs untrusted CSS through PostCSS (CMS themes, user-uploaded styles, browser-extension/userstyle processors, build pipelines for third-party packages, blog comment renderers, etc.). Details The dangerous chain lives in lib/previous-map.js and is wired into every Input construction at…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6g55-p6wh-862q

  2. Revision 1 · created ·

    Published from osv record GHSA-6g55-p6wh-862q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45623

Advisory: PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments
IDs: CVE-2026-45623, GHSA-6g55-p6wh-862q
Record: https://patchnext.com/advisories/cve-2026-45623 (revision 2, source checked 26 Oct 2026, 12:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: postcss 8.5.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm postcss: affected <= 8.5.11; fixed in 8.5.12

## Suggested inspection (read-only)
- `npm ls postcss --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on postcss.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6g55-p6wh-862q (OSV record GHSA-6g55-p6wh-862q lists affected ranges: npm postcss >=0 <8.5.12 (fixed))
- Verified: https://github.com/advisories/GHSA-6g55-p6wh-862q (GitHub-reviewed advisory GHSA-6g55-p6wh-862q lists affected ranges: npm postcss >=0 <=8.5.11)

Commands are suggestions: review each one before running it.

Loading voting…