Skip to content

← Actionable
Critical, CVSS 10.0amended

LiquidJS is Vulnerable to Remote Code Execution

CVE-2026-45618GHSA-gf2q-c269-pqgc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (liquidjs 10.26.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm liquidjs

    Affected
    < 10.26.0
    Fixed in
    10.26.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-45618: 0.82% estimated exploitation activity in the next 30 days; percentile 57.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary It is possible to execute arbitrary code with crafted templates Details <details <summary 1|valueOf - this when evaluating the filter </summary </details <details <summary function calls with a controlled first argument via comprable </summary <img width="1426" height="717" alt="image" src="https://github.com/user-attachments/assets/0618eb81-fb0d-4100-a6a0-556982decf8a" / </details <details<summarychanging the prototype of things</summary <img width="723" height="211" alt="image" src="https://github.com/user-attachments/assets/c05f4c4a-4151-4765-b569-3300ad837668" / </details When calling functions via the comparable gadget, this will be the scope. By overwriting this.loader.lookup and this.readFile, to fully control what goes into this.parse, and while controlling this, a reference to the Function constructor can be obtained, which then allows executing arbitrary code. PoC Complete instructions, including specific configuration details, to reproduce the vulnerability. Impact…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gf2q-c269-pqgc

  2. Revision 2 · amended ·

    Amended from osv record GHSA-gf2q-c269-pqgc

  3. Revision 1 · created ·

    Published from ghsa record GHSA-gf2q-c269-pqgc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45618

Advisory: LiquidJS is Vulnerable to Remote Code Execution
IDs: CVE-2026-45618, GHSA-gf2q-c269-pqgc
Record: https://patchnext.com/advisories/cve-2026-45618 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: liquidjs 10.26.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm liquidjs: affected < 10.26.0; fixed in 10.26.0

## Suggested inspection (read-only)
- `npm ls liquidjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on liquidjs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gf2q-c269-pqgc (GitHub-reviewed advisory GHSA-gf2q-c269-pqgc lists affected ranges: npm liquidjs >=0 <10.26.0)
- Verified: https://osv.dev/vulnerability/GHSA-gf2q-c269-pqgc (OSV record GHSA-gf2q-c269-pqgc lists affected ranges: npm liquidjs >=0 <10.26.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…