Skip to content

← Actionable
Critical, CVSS 9.9amended

DIRAC is vulnerable to RCE in RequestManager due to eval on untrusted input

CVE-2026-45579GHSA-9jpv-c7p4-997x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dirac 9.1.10, 9.0.22, 8.0.79), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI dirac

    Affected
    >= 6, < 8.0.79>= 8.1.0a1, < 9.0.22>= 9.1.0, < 9.1.10
    Fixed in
    9.1.10, 8.0.79, 9.0.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-45579: 0.86% estimated exploitation activity in the next 30 days; percentile 58.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An remote code execution vulnerability exists in RequestManager due to the use of eval on untrusted input that allows any authenticated user to run code/commands on the DIRAC server as the system user running the DIRAC services. Details The exportgetRequestCountersWeb function is callable by any authenticated user and just passes its parameters directly to the database instance: https://github.com/DIRACGrid/DIRAC/blob/f7e0a3ac153315030fb3520e8ca747f013758967/src/DIRAC/RequestManagementSystem/Service/ReqManagerHandler.py#L270 If the groupingAttribute string is unrecognised, Request. is prepended to it and the result is passed into an eval() call: https://github.com/DIRACGrid/DIRAC/blob/f7e0a3ac153315030fb3520e8ca747f013758967/src/DIRAC/RequestManagementSystem/DB/RequestDB.py#L766-L776 By passing in a dunder string that is applicable to the Request object, it's possible to work back up to functions in the os module and trigger them to be called in the server context. There are…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9jpv-c7p4-997x

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9jpv-c7p4-997x

  3. Revision 1 · created ·

    Published from ghsa record GHSA-9jpv-c7p4-997x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45579

Advisory: DIRAC is vulnerable to RCE in RequestManager due to eval on untrusted input
IDs: CVE-2026-45579, GHSA-9jpv-c7p4-997x
Record: https://patchnext.com/advisories/cve-2026-45579 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dirac 9.1.10, 9.0.22, 8.0.79. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI dirac: affected >= 6, < 8.0.79; >= 8.1.0a1, < 9.0.22; >= 9.1.0, < 9.1.10; fixed in 9.1.10, 8.0.79, 9.0.22

## Suggested inspection (read-only)
- `python -m pip show dirac`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dirac.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9jpv-c7p4-997x (GitHub-reviewed advisory GHSA-9jpv-c7p4-997x lists affected ranges: PyPI dirac >=6 =8.1.0a1 =9.1.0 <9.1.10)
- Verified: https://osv.dev/vulnerability/GHSA-9jpv-c7p4-997x (OSV record GHSA-9jpv-c7p4-997x lists affected ranges: PyPI dirac >=6 =8.1.0a1 =9.1.0 <9.1.10 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…