Decidim: Push subscriptions can be abused for server-side requests
CVE-2026-45573GHSA-2g9c-vf8h-prxx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim-core 0.32.0, 0.31.5, 0.30.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems decidim-core
- Affected
- < 0.30.9>= 0.31.0.rc1, < 0.31.5>= 0.32.0.rc1, < 0.32.0
- Fixed in
- 0.31.5, 0.32.0, 0.30.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2g9c-vf8h-prxx lists affected ranges: RubyGems decidim-core >=0 =0.31.0.rc1 =0.32.0.rc1 <0.32.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-45573: 0.26% estimated exploitation activity in the next 30 days; percentile 17.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description The push-subscription endpoint stores an attacker-controlled delivery URL, and the notification send path becomes an outbound-request sink when VAPID delivery is enabled. The practical result is an authenticated, stored, mostly blind SSRF primitive to arbitrary HTTPS endpoints reachable from the app server. Technical description When VAPID delivery is enabled, the notification subscription flow stores the client-supplied push endpoint without checking that it belongs to an approved push service. The send path later passes that stored URL to WebPush.payloadsend, turning the subscription into an attacker-controlled outbound request destination. This is the source-to-sink chain: 1. Source: attacker-controlled subscription.endpoint in the JSON body posted to POST /notificationssubscriptions. 2. Persistence: params[:endpoint] is stored under user.notificationsettings["subscriptions"]. 3. Retrieval: user.notificationssubscriptions.values returns that stored endpoint later. 4.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2g9c-vf8h-prxx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45573 Advisory: Decidim: Push subscriptions can be abused for server-side requests IDs: CVE-2026-45573, GHSA-2g9c-vf8h-prxx Record: https://patchnext.com/advisories/cve-2026-45573 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: decidim-core 0.32.0, 0.31.5, 0.30.9. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems decidim-core: affected < 0.30.9; >= 0.31.0.rc1, < 0.31.5; >= 0.32.0.rc1, < 0.32.0; fixed in 0.31.5, 0.32.0, 0.30.9 ## Suggested inspection (read-only) - RubyGems decidim-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on decidim-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2g9c-vf8h-prxx (GitHub-reviewed advisory GHSA-2g9c-vf8h-prxx lists affected ranges: RubyGems decidim-core >=0 =0.31.0.rc1 =0.32.0.rc1 <0.32.0) Commands are suggestions: review each one before running it.
Loading voting…