Decidim: HTML content blocks allow stored script execution
CVE-2026-45572GHSA-533c-2vh9-4r86
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim-core 0.32.0, 0.31.5, 0.30.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems decidim-core
- Affected
- < 0.30.9>= 0.31.0.rc1, < 0.31.5>= 0.32.0.rc1, < 0.32.0
- Fixed in
- 0.31.5, 0.32.0, 0.30.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-533c-2vh9-4r86 lists affected ranges: RubyGems decidim-core >=0 =0.31.0.rc1 =0.32.0.rc1 <0.32.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-45572: 0.25% estimated exploitation activity in the next 30 days; percentile 16.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description A privileged admin user who can edit an affected landing page can store arbitrary HTML/JavaScript in an HTML block, and the public page renders it with htmlsafe and no output escaping. Technical description This issue lets any admin who can edit an affected landing page store arbitrary HTML and JavaScript in an HTML block. The block is then rendered back through Decidim::ContentBlocks::HtmlCell#htmlcontent without a sanitization boundary, so the script executes later in visitor's browsers. <img width="1541" height="439" alt="decidim-html-xss-01" src="https://github.com/user-attachments/assets/acae1c06-8acb-49be-ab12-aabae33190ce" / <img width="1540" height="752" alt="decidim-html-xss-02" src="https://github.com/user-attachments/assets/a2f1fa7f-03f3-4d17-b58b-f4db865443e9" / Impact - A user with landing-page editing rights for an affected scope can persist JavaScript that executes in visitor's browsers on that page. - Because exploitation already requires privileged…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-533c-2vh9-4r86
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45572 Advisory: Decidim: HTML content blocks allow stored script execution IDs: CVE-2026-45572, GHSA-533c-2vh9-4r86 Record: https://patchnext.com/advisories/cve-2026-45572 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: decidim-core 0.32.0, 0.31.5, 0.30.9. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems decidim-core: affected < 0.30.9; >= 0.31.0.rc1, < 0.31.5; >= 0.32.0.rc1, < 0.32.0; fixed in 0.31.5, 0.32.0, 0.30.9 ## Suggested inspection (read-only) - RubyGems decidim-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on decidim-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-533c-2vh9-4r86 (GitHub-reviewed advisory GHSA-533c-2vh9-4r86 lists affected ranges: RubyGems decidim-core >=0 =0.31.0.rc1 =0.32.0.rc1 <0.32.0) Commands are suggestions: review each one before running it.
Loading voting…