Skip to content

← Actionable
Medium, CVSS 4.0

Netty: Unix-socket fd receive leaks descriptors when peer sends two at once

CVE-2026-45536GHSA-w573-9ffj-6ff9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-transport-native-epoll 4.2.15.Final, 4.1.135.Final; io.netty:netty-transport-native-kqueue 4.2.15.Final, 4.1.135.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-w573-9ffj-6ff9 lists affected ranges: Maven io.netty:netty-transport-native-epoll >=4.2.0.Final =0 =4.2.0.Final =0 <=4.1.134.Final

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.0 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-45536: 0.14% estimated exploitation activity in the next 30 days; percentile 3.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

nettyunixsocketrecvFd sets msgcontrol to char control[CMSGSPACE(sizeof(int))] (line 940) — 24 bytes on 64-bit Linux. A peer-sent SCMRIGHTS cmsg carrying two ints has cmsglen = CMSGLEN(8) = 24, which fits exactly with no MSGCTRUNC, so the kernel installs both fds in the receiving process. The subsequent check cmsg-cmsglen == CMSGLEN(sizeof(int)) (line 972, expected 20) fails, the branch that would read the fd is skipped, and neither installed fd is closed. The for(;;) loop calls recvmsg again (non-blocking → EAGAIN → Java maps to 0 → read loop exits normally), leaving two leaked fds per message. There is no MSGCTRUNC handling. Reachable via Epoll/KQueue DomainSocketChannel when the application opts into DomainSocketReadMode.FILEDESCRIPTORS (non-default).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w573-9ffj-6ff9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45536

Advisory: Netty: Unix-socket fd receive leaks descriptors when peer sends two at once
IDs: CVE-2026-45536, GHSA-w573-9ffj-6ff9
Record: https://patchnext.com/advisories/cve-2026-45536 (revision 1, source checked 26 Oct 2026, 16:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-transport-native-epoll 4.2.15.Final, 4.1.135.Final; io.netty:netty-transport-native-kqueue 4.2.15.Final, 4.1.135.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-transport-native-epoll: affected >= 4.2.0.Final, <= 4.2.14.Final; <= 4.1.134.Final; fixed in 4.2.15.Final, 4.1.135.Final
- Maven io.netty:netty-transport-native-kqueue: affected >= 4.2.0.Final, <= 4.2.14.Final; <= 4.1.134.Final; fixed in 4.2.15.Final, 4.1.135.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-transport-native-epoll: check the installed version with your package manager.
- Maven io.netty:netty-transport-native-kqueue: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-transport-native-epoll, io.netty:netty-transport-native-kqueue.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w573-9ffj-6ff9 (GitHub-reviewed advisory GHSA-w573-9ffj-6ff9 lists affected ranges: Maven io.netty:netty-transport-native-epoll >=4.2.0.Final =0 =4.2.0.Final =0 <=4.1.134.Final)

Commands are suggestions: review each one before running it.

Loading voting…