Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue
CVE-2026-45505GHSA-v853-w46p-fv2h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-broker 6.2.6, 5.19.7; org.apache.activemq:apache-activemq 6.2.6, 5.19.7; org.apache.activemq:activemq-all 6.2.6, 5.19.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.activemq:activemq-broker
- Affected
- < 5.19.7>= 6.0.0, < 6.2.6
- Fixed in
- 6.2.6, 5.19.7
Maven org.apache.activemq:apache-activemq
- Affected
- < 5.19.7>= 6.0.0, < 6.2.6
- Fixed in
- 6.2.6, 5.19.7
Maven org.apache.activemq:activemq-all
- Affected
- < 5.19.7>= 6.0.0, < 6.2.6
- Fixed in
- 6.2.6, 5.19.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v853-w46p-fv2h lists affected ranges: Maven org.apache.activemq:activemq-broker >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-45505: 0.60% estimated exploitation activity in the next 30 days; percentile 48.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. Non-parenthesized discovery wrappers such as masterslave:vm://...,... and static:vm://... incorrectly pass validation allowing bypass of fix in CVE-2026-34197. Original description from CVE-2026-34197. Apache ActiveMQ exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery UR that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v853-w46p-fv2h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45505 Advisory: Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue IDs: CVE-2026-45505, GHSA-v853-w46p-fv2h Record: https://patchnext.com/advisories/cve-2026-45505 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-broker 6.2.6, 5.19.7; org.apache.activemq:apache-activemq 6.2.6, 5.19.7; org.apache.activemq:activemq-all 6.2.6, 5.19.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.activemq:activemq-broker: affected < 5.19.7; >= 6.0.0, < 6.2.6; fixed in 6.2.6, 5.19.7 - Maven org.apache.activemq:apache-activemq: affected < 5.19.7; >= 6.0.0, < 6.2.6; fixed in 6.2.6, 5.19.7 - Maven org.apache.activemq:activemq-all: affected < 5.19.7; >= 6.0.0, < 6.2.6; fixed in 6.2.6, 5.19.7 ## Suggested inspection (read-only) - Maven org.apache.activemq:activemq-broker: check the installed version with your package manager. - Maven org.apache.activemq:apache-activemq: check the installed version with your package manager. - Maven org.apache.activemq:activemq-all: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.activemq:activemq-broker, org.apache.activemq:apache-activemq, org.apache.activemq:activemq-all. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v853-w46p-fv2h (GitHub-reviewed advisory GHSA-v853-w46p-fv2h lists affected ranges: Maven org.apache.activemq:activemq-broker >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.2.6) Commands are suggestions: review each one before running it.
Loading voting…