Skip to content

← Actionable
High, CVSS 7.5

Netty: SNI handler pre-allocates up to 16 MiB from nine attacker bytes

CVE-2026-45416GHSA-x4gw-5cx5-pgmh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-handler 4.2.15.Final, 4.1.135.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven io.netty:netty-handler

    Affected
    >= 4.2.0.Final, <= 4.2.14.Final<= 4.1.134.Final
    Fixed in
    4.2.15.Final, 4.1.135.Final

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-45416: 0.92% estimated exploitation activity in the next 30 days; percentile 60.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SslClientHelloHandler.decode() reads the 24-bit TLS handshake length and, when the ClientHello does not fit in the first record, eagerly allocates ctx.alloc().buffer(handshakeLength) (line 161). The guard at line 140 is handshakeLength maxClientHelloLength && maxClientHelloLength != 0, and the commonly-used SniHandler/AbstractSniHandler constructors (SniHandler(Mapping), SniHandler(AsyncMapping), AbstractSniHandler()) pass maxClientHelloLength=0 and handshakeTimeoutMillis=0, so the length guard is disabled and no timeout is scheduled. A 16 MiB request exceeds the default pooled chunk size and becomes a huge/unpooled allocation performed immediately. The buffer is retained in the handler until the channel closes.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x4gw-5cx5-pgmh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45416

Advisory: Netty: SNI handler pre-allocates up to 16 MiB from nine attacker bytes
IDs: CVE-2026-45416, GHSA-x4gw-5cx5-pgmh
Record: https://patchnext.com/advisories/cve-2026-45416 (revision 1, source checked 26 Oct 2026, 16:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-handler 4.2.15.Final, 4.1.135.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-handler: affected >= 4.2.0.Final, <= 4.2.14.Final; <= 4.1.134.Final; fixed in 4.2.15.Final, 4.1.135.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-handler: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-handler.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x4gw-5cx5-pgmh (GitHub-reviewed advisory GHSA-x4gw-5cx5-pgmh lists affected ranges: Maven io.netty:netty-handler >=4.2.0.Final =0 <=4.1.134.Final)

Commands are suggestions: review each one before running it.

Loading voting…