Skip to content

← Actionable
Medium, CVSS 6.0

Decidim: CSV census record endpoints improper authorization

CVE-2026-45415GHSA-q79h-67vx-m9xg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim-verifications 0.32.0, 0.31.5, 0.30.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems decidim-verifications

    Affected
    < 0.30.9>= 0.31.0.rc1, < 0.31.5>= 0.32.0.rc1, < 0.32.0
    Fixed in
    0.31.5, 0.32.0, 0.30.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.0 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:L
EPSS
  • CVE-2026-45415: 0.43% estimated exploitation activity in the next 30 days; percentile 36.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description A participant manager can access and modify the CSV census record admin forms. Technical description The CSV census admin record-management surface under /admin/csvcensus/censuslogs does not enforce admin-only authorization before rendering or mutating Decidim::Verifications::CsvDatum. A participant manager (which can only manage participants) can therefore open the admin forms, create or update census rows, and delete rows directly. Reproduction steps: 1. Sign in a participant admin and open http://localhost:3000/admin/csvcensus/censuslogs/newrecord in the browser. Confirm the create form loads even though the session is not a full admin. <img width="1541" height="274" alt="decidim-census-01" src="https://github.com/user-attachments/assets/859ee101-746f-4acb-8051-27036689f1b3" / <img width="1538" height="363" alt="decidim-census-02" src="https://github.com/user-attachments/assets/85bbb004-a999-46dc-856c-fd32b50ced2c" / Note that normal participant accounts were not able…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q79h-67vx-m9xg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45415

Advisory: Decidim: CSV census record endpoints improper authorization
IDs: CVE-2026-45415, GHSA-q79h-67vx-m9xg
Record: https://patchnext.com/advisories/cve-2026-45415 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: decidim-verifications 0.32.0, 0.31.5, 0.30.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems decidim-verifications: affected < 0.30.9; >= 0.31.0.rc1, < 0.31.5; >= 0.32.0.rc1, < 0.32.0; fixed in 0.31.5, 0.32.0, 0.30.9

## Suggested inspection (read-only)
- RubyGems decidim-verifications: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on decidim-verifications.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q79h-67vx-m9xg (GitHub-reviewed advisory GHSA-q79h-67vx-m9xg lists affected ranges: RubyGems decidim-verifications >=0 =0.31.0.rc1 =0.32.0.rc1 <0.32.0)

Commands are suggestions: review each one before running it.

Loading voting…