Decidim: JWT-backed authentication can be replayed across organizations
CVE-2026-45414GHSA-r3v7-5x4c-c69q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim 0.32.0, 0.31.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems decidim
- Affected
- < 0.31.5>= 0.32.0.rc1, < 0.32.0
- Fixed in
- 0.31.5, 0.32.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r3v7-5x4c-c69q lists affected ranges: RubyGems decidim >=0 =0.32.0.rc1 <0.32.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-45414: 0.45% estimated exploitation activity in the next 30 days; percentile 39.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description A JWT issued to an Org 1 account is accepted on the Org 2 API and can read the admin-only GraphQL participantDetails field for an Org 2 participant. The same trust-boundary problem also affects API-user authentication: an Org 1 API user can use a JWT on the Org 1 host and replay that JWT to the Org 2 API to read Org 2 participant personal data and reach Org 2's proposal.answer mutation path. Technical description The current host selects the Decidim organization context, but JWT-backed API authentication is not sufficiently bound to that host organization. As a result, the API can process a request in Org 2's context while still trusting an authenticated principal from Org 1. Reproduction steps: 1. Use an API key provided by the system administrator that is assigned to organization 1 to create the JWT token or get the JWT token shown in the response when logged in as the organization admin. <img width="1080" height="1119" alt="decidim-jwt-01"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r3v7-5x4c-c69q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45414 Advisory: Decidim: JWT-backed authentication can be replayed across organizations IDs: CVE-2026-45414, GHSA-r3v7-5x4c-c69q Record: https://patchnext.com/advisories/cve-2026-45414 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: decidim 0.32.0, 0.31.5. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems decidim: affected < 0.31.5; >= 0.32.0.rc1, < 0.32.0; fixed in 0.31.5, 0.32.0 ## Suggested inspection (read-only) - RubyGems decidim: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on decidim. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r3v7-5x4c-c69q (GitHub-reviewed advisory GHSA-r3v7-5x4c-c69q lists affected ranges: RubyGems decidim >=0 =0.32.0.rc1 <0.32.0) Commands are suggestions: review each one before running it.
Loading voting…