Open WebUI has a Server-Side Request Forgery (SSRF) bypass in validate_url
CVE-2026-45400GHSA-8w7q-q5jp-jvgx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webui
- Affected
- <= 0.9.4
- Fixed in
- 0.9.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8w7q-q5jp-jvgx lists affected ranges: PyPI open-webui >=0 <0.9.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8w7q-q5jp-jvgx lists affected ranges: PyPI open-webui >=0 <=0.9.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-45400: 0.29% estimated exploitation activity in the next 30 days; percentile 21.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In the open-webui project, a parsing difference between the urlparse and requests libraries led to an SSRF bypass vulnerability. Details In the current project, URL validation is performed using the function validateurl. <img width="1323" height="1145" alt="QQ20260322-202854-22-1" src="https://github.com/user-attachments/assets/896d19f2-c7c3-499a-9052-12aea756ac47" / The current checking logic uses urlparse to parse the hostname part of the URL for verification. <img width="1122" height="429" alt="QQ20260322-203014-22-2" src="https://github.com/user-attachments/assets/653520e9-e311-4a5e-8345-a2446e217d88" / However, there are actually differences in parsing between urlparse and the library that actually sends the request. For example, in files.py, validateurl is used first for URL validation, and then requests.get is used to send the request. <img width="1269" height="915" alt="QQ20260322-203122-22-3"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8w7q-q5jp-jvgx
- Revision 1 · created ·
Published from osv record GHSA-8w7q-q5jp-jvgx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45400 Advisory: Open WebUI has a Server-Side Request Forgery (SSRF) bypass in `validate_url` IDs: CVE-2026-45400, GHSA-8w7q-q5jp-jvgx Record: https://patchnext.com/advisories/cve-2026-45400 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webui: affected <= 0.9.4; fixed in 0.9.5 ## Suggested inspection (read-only) - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8w7q-q5jp-jvgx (OSV record GHSA-8w7q-q5jp-jvgx lists affected ranges: PyPI open-webui >=0 <0.9.5 (fixed)) - Verified: https://github.com/advisories/GHSA-8w7q-q5jp-jvgx (GitHub-reviewed advisory GHSA-8w7q-q5jp-jvgx lists affected ranges: PyPI open-webui >=0 <=0.9.4) Commands are suggestions: review each one before running it.
Loading voting…