Skip to content

← Actionable
High, CVSS 7.1amended

Open WebUI: Low-privilege authenticated users can enumerate and stop global background tasks, causing system-wide chat disruption

CVE-2026-45399GHSA-8jjp-r2w2-4v22

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H
EPSS
  • CVE-2026-45399: 0.27% estimated exploitation activity in the next 30 days; percentile 19.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Any authenticated user with low privileges can enumerate active background tasks across the system and stop tasks belonging to other users via the GET /api/tasks and POST /api/tasks/stop/{taskid} methods. This allows a casual user to disrupt system-wide chat usage by continuously canceling other users' active tasks. This is a real authorization vulnerability affecting integrity and usability in multi-user deployments. Details Open WebUI exposes GET /api/tasks and POST /api/tasks/stop/{taskid} to any verified user. These endpoints operate on a global task namespace and accept raw taskid values without checking whether the task belongs to the current caller. As a result, a normal authenticated user can enumerate active global task IDs and stop tasks belonging to other users. Root cause: 1. Route authorization is too weak. In backend/openwebui/main.py, both endpoints only require getverifieduser: getverifieduser accepts both user and admin roles in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8jjp-r2w2-4v22

  2. Revision 1 · created ·

    Published from osv record GHSA-8jjp-r2w2-4v22

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45399

Advisory: Open WebUI: Low-privilege authenticated users can enumerate and stop global background tasks, causing system-wide chat disruption
IDs: CVE-2026-45399, GHSA-8jjp-r2w2-4v22
Record: https://patchnext.com/advisories/cve-2026-45399 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected <= 0.8.12; fixed in 0.9.0

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8jjp-r2w2-4v22 (OSV record GHSA-8jjp-r2w2-4v22 lists affected ranges: PyPI open-webui >=0 <0.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8jjp-r2w2-4v22 (GitHub-reviewed advisory GHSA-8jjp-r2w2-4v22 lists affected ranges: PyPI open-webui >=0 <=0.8.12)

Commands are suggestions: review each one before running it.

Loading voting…