Skip to content

← Actionable
Medium, CVSS 5.3amended

Open WebUI Vulnerable to Unauthenticated RAG Configuration Disclosure

CVE-2026-45397GHSA-65pg-qhhw-mxwg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-45397: 0.75% estimated exploitation activity in the next 30 days; percentile 55.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Type: Information Disclosure / Missing Authentication Severity: Medium Component: backend/openwebui/routers/retrieval.py — getstatus() (GET /) Affected Endpoint: GET /api/v1/retrieval/ Affected Version: Open WebUI main branch — confirmed unpatched through v0.9.2 Authentication Required: None — internet-facing with zero credentials CVSSv3.1 Score: 5.3 (AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N) --- Summary GET /api/v1/retrieval/ returns live RAG pipeline configuration to any unauthenticated HTTP client. No Authorization header, cookie, or API key is required. Every adjacent endpoint on the same router (/embedding, /config) is correctly guarded by getadminuser making this a targeted omission. --- Root Cause backend/openwebui/routers/retrieval.py:262 Compare with every adjacent endpoint on the same router: --- Proof Of Concept — No Token Required --- Disclosed Information and Its Value to an Attacker | Field | What it reveals | |---|---| | RAGEMBEDDINGENGINE | Backend type…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-65pg-qhhw-mxwg

  2. Revision 1 · created ·

    Published from osv record GHSA-65pg-qhhw-mxwg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45397

Advisory: Open WebUI Vulnerable to Unauthenticated RAG Configuration Disclosure
IDs: CVE-2026-45397, GHSA-65pg-qhhw-mxwg
Record: https://patchnext.com/advisories/cve-2026-45397 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected < 0.9.5; fixed in 0.9.5

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-65pg-qhhw-mxwg (OSV record GHSA-65pg-qhhw-mxwg lists affected ranges: PyPI open-webui >=0 <0.9.5 (fixed))
- Verified: https://github.com/advisories/GHSA-65pg-qhhw-mxwg (GitHub-reviewed advisory GHSA-65pg-qhhw-mxwg lists affected ranges: PyPI open-webui >=0 <0.9.5)

Commands are suggestions: review each one before running it.

Loading voting…