Decidim: Private exports can be downloaded through reusable links
CVE-2026-45377GHSA-767h-63j4-5226
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim-core 0.32.0, 0.31.5, 0.30.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems decidim-core
- Affected
- < 0.30.9>= 0.31.0.rc1, < 0.31.5>= 0.32.0.rc1, < 0.32.0
- Fixed in
- 0.31.5, 0.32.0, 0.30.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-767h-63j4-5226 lists affected ranges: RubyGems decidim-core >=0 =0.31.0.rc1 =0.32.0.rc1 <0.32.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-45377: 0.45% estimated exploitation activity in the next 30 days; percentile 39.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description The normal downloadyourdata flow requires the requester to be logged in as the export owner, but the resulting Active Storage blob redirect URL can be replayed without authentication by anyone who obtains it. Technical description This private export flow turns an authenticated, user-scoped download into a reusable bearer link because the protected Decidim endpoint redirects to the underlying Active Storage blob URL. Decidim::DownloadYourDataController#downloadfile correctly scopes the export record to currentuser, so the wrapper route itself is not directly accessible to another user. However, once the owner performs that authenticated GET request, the response redirects to a signed Active Storage URL that is no longer bound to the user session. Anyone who learns that URL can replay it and retrieve the file without being logged in as the export owner. Because the blob redirect URL is delivered through a GET request and appears in the redirect chain, it is more likely to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-767h-63j4-5226
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45377 Advisory: Decidim: Private exports can be downloaded through reusable links IDs: CVE-2026-45377, GHSA-767h-63j4-5226 Record: https://patchnext.com/advisories/cve-2026-45377 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: decidim-core 0.32.0, 0.31.5, 0.30.9. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems decidim-core: affected < 0.30.9; >= 0.31.0.rc1, < 0.31.5; >= 0.32.0.rc1, < 0.32.0; fixed in 0.31.5, 0.32.0, 0.30.9 ## Suggested inspection (read-only) - RubyGems decidim-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on decidim-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-767h-63j4-5226 (GitHub-reviewed advisory GHSA-767h-63j4-5226 lists affected ranges: RubyGems decidim-core >=0 =0.31.0.rc1 =0.32.0.rc1 <0.32.0) Commands are suggestions: review each one before running it.
Loading voting…