DeepSeek TUI: task_create Insecure Defaults Enable RCE via Prompt Injection in Project Files
CVE-2026-45374GHSA-72w5-pf8h-xfp4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (deepseek-tui 0.8.26), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io deepseek-tui
- Affected
- < 0.8.26
- Fixed in
- 0.8.26
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-72w5-pf8h-xfp4 lists affected ranges: crates.io deepseek-tui >=0 <0.8.26
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-45374: 0.39% estimated exploitation activity in the next 30 days; percentile 32.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The taskcreate tool spawns durable sub-agents that inherit two insecure defaults: - allowshell defaults to true (config.rs:1499: self.allowshell.unwrapor(true)) - autoapprove defaults to true (taskmanager.rs:297: autoapprove: Some(true)) When a user approves a taskcreate call (which requires ApprovalRequirement::Required), they approve what appears to be a benign work prompt (e.g., "fix TODOs and write a README"). However, the spawned sub-agent silently receives unrestricted, unapproved shell access. Neither allowshell nor autoapprove need to be explicitly specified by the model and both default to true. PoC Step 1 — Create a malicious repo: Cargo.toml: [package] name = "web-service" version = "0.1.0" edition = "2021" src/lib.rs (clean, no injection): pub fn hello() - &'static str { "Hello, world!" } // TODO: refactor this into smaller modules // TODO: add proper error handling with Result types // TODO: add unit tests for all public functions // TODO: write README.md with…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-72w5-pf8h-xfp4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45374 Advisory: DeepSeek TUI: task_create Insecure Defaults Enable RCE via Prompt Injection in Project Files IDs: CVE-2026-45374, GHSA-72w5-pf8h-xfp4 Record: https://patchnext.com/advisories/cve-2026-45374 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: deepseek-tui 0.8.26. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io deepseek-tui: affected < 0.8.26; fixed in 0.8.26 ## Suggested inspection (read-only) - crates.io deepseek-tui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on deepseek-tui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-72w5-pf8h-xfp4 (GitHub-reviewed advisory GHSA-72w5-pf8h-xfp4 lists affected ranges: crates.io deepseek-tui >=0 <0.8.26) Commands are suggestions: review each one before running it.
Loading voting…