Skip to content

← Actionable
Critical, CVSS 10.0amended

utcp-cli Vulnerable to Command Injection via Unsanitized Argument Substitution in CLI Communication Protocol

CVE-2026-45369GHSA-33p6-5jxp-p3x4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (utcp-cli 1.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI utcp-cli

    Affected
    <= 1.1.1
    Fixed in
    1.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-45369: 0.32% estimated exploitation activity in the next 30 days; percentile 25.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The substituteutcpargs method in clicommunicationprotocol.py inserts user-controlled toolargs values directly into shell command strings without any sanitization or escaping. These commands are then executed via /bin/bash -c (Unix) or powershell.exe -Command (Windows), allowing an attacker to inject arbitrary shell commands. Affected File plugins/communicationprotocols/cli/src/utcpcli/clicommunicationprotocol.py Vulnerable Code The substituted command is then embedded directly into a shell script: And executed via: Proof of Concept Given a tool defined as: Calling with: Produces and executes: This results in full Remote Code Execution on the host system. Patched Fixed in utcp-cli 1.1.2. substituteutcpargs now shell-quotes every substituted value: shlex.quote on Unix, a PowerShell single-quoted literal on Windows. Each UTCPARG...UTCPEND placeholder therefore expands to exactly one shell token, blocking metacharacter injection (;, |, &, backticks, $(), newlines). Behavior…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-33p6-5jxp-p3x4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-33p6-5jxp-p3x4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-33p6-5jxp-p3x4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45369

Advisory: utcp-cli Vulnerable to Command Injection via Unsanitized Argument Substitution in CLI Communication Protocol
IDs: CVE-2026-45369, GHSA-33p6-5jxp-p3x4
Record: https://patchnext.com/advisories/cve-2026-45369 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: utcp-cli 1.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI utcp-cli: affected <= 1.1.1; fixed in 1.1.2

## Suggested inspection (read-only)
- `python -m pip show utcp-cli`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on utcp-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-33p6-5jxp-p3x4 (GitHub-reviewed advisory GHSA-33p6-5jxp-p3x4 lists affected ranges: PyPI utcp-cli >=0 <=1.1.1)
- Verified: https://osv.dev/vulnerability/GHSA-33p6-5jxp-p3x4 (OSV record GHSA-33p6-5jxp-p3x4 lists affected ranges: PyPI utcp-cli >=0 <1.1.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…