Better Auth: Rate limiter keys IPv6 addresses individually and is bypassable via prefix rotation
CVE-2026-45364GHSA-p6v2-xcpg-h6xw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.5.0-beta.9, 1.4.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm better-auth
- Affected
- < 1.4.17>= 1.5.0-beta.1, < 1.5.0-beta.9
- Fixed in
- 1.4.17, 1.5.0-beta.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p6v2-xcpg-h6xw lists affected ranges: npm better-auth >=0 =1.5.0-beta.1 <1.5.0-beta.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p6v2-xcpg-h6xw lists affected ranges: npm better-auth >=0 =1.5.0-beta.1 <1.5.0-beta.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2026-45364: 0.29% estimated exploitation activity in the next 30 days; percentile 22.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Am I affected? Users are affected if all of the following are true: - Their app uses better-auth at a version < 1.4.17, or at a v1.5 prerelease tagged <= 1.5.0-beta.8. - The apps authentication endpoints serve clients reachable over IPv6. Most managed hosts including Cloudflare, Vercel, Fly.io, AWS Application Load Balancer, and Google Cloud Load Balancing advertise IPv6 by default. - The app's rate-limit configuration is enabled (the production default) and relies on the leftmost x-forwarded-for value (the stock setup) or any other configured IP-bearing header. If users are on 1.4.16 specifically, the normalizeIP helper exists in your version but the IPv6 prefix length defaults to /128. Stock config still permits prefix rotation because no prefix mask is applied. Either upgrade to 1.4.17 or set advanced.ipAddress.ipv6Subnet: 64 in the config. If applications do not use the rate limiter, or if the deployment serves only IPv4 clients, the prefix-rotation vector does not apply. The…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p6v2-xcpg-h6xw
- Revision 1 · created ·
Published from osv record GHSA-p6v2-xcpg-h6xw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45364 Advisory: Better Auth: Rate limiter keys IPv6 addresses individually and is bypassable via prefix rotation IDs: CVE-2026-45364, GHSA-p6v2-xcpg-h6xw Record: https://patchnext.com/advisories/cve-2026-45364 (revision 2, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: better-auth 1.5.0-beta.9, 1.4.17. A vendor fix does not mean a deployment is fixed. ## Affected components - npm better-auth: affected < 1.4.17; >= 1.5.0-beta.1, < 1.5.0-beta.9; fixed in 1.4.17, 1.5.0-beta.9 ## Suggested inspection (read-only) - `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on better-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p6v2-xcpg-h6xw (OSV record GHSA-p6v2-xcpg-h6xw lists affected ranges: npm better-auth >=0 =1.5.0-beta.1 <1.5.0-beta.9 (fixed)) - Verified: https://github.com/advisories/GHSA-p6v2-xcpg-h6xw (GitHub-reviewed advisory GHSA-p6v2-xcpg-h6xw lists affected ranges: npm better-auth >=0 =1.5.0-beta.1 <1.5.0-beta.9) Commands are suggestions: review each one before running it.
Loading voting…