Skip to content

← Actionable
Medium, CVSS 6.5amended

Open WebUI Exposes System Prompt to Regular User [Non-Admin]

CVE-2026-45351GHSA-jh9g-8jqw-m2qx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.8.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-45351: 0.28% estimated exploitation activity in the next 30 days; percentile 20.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A regular user [non-admin] can view the system prompt of the model which is set by an admin. Details When a regular user [non-admin] logs into the application, a http://IP:8080/api/models? web request is initiated by the application and in response, it reveals the system prompt of available models set by admin on models pages in workspace affecting the confidentiality of application Affected System Open WebUI v0.6.40 "main" branch Vulnerability Details and Advisory from OWASP LLM07:2025 System Prompt Leakage - https://genai.owasp.org/llmrisk/llm072025-system-prompt-leakage/ PoC 1. Regular User [Non-Admin] login on Open WebUI application. 2. A series of web requests get generated by the application, and the http://IP:8080/api/models? is also gets generated by application . 3. The response of http://IP:8080/api/models? web request reveals the system prompt of all the available models which is set is by the admin on models pages in workspace. <img width="940" height="352"…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jh9g-8jqw-m2qx

  2. Revision 1 · created ·

    Published from osv record GHSA-jh9g-8jqw-m2qx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45351

Advisory: Open WebUI Exposes System Prompt to Regular User [Non-Admin]
IDs: CVE-2026-45351, GHSA-jh9g-8jqw-m2qx
Record: https://patchnext.com/advisories/cve-2026-45351 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.8.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected <= 0.8.8; fixed in 0.8.9

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jh9g-8jqw-m2qx (OSV record GHSA-jh9g-8jqw-m2qx lists affected ranges: PyPI open-webui >=0 <0.8.9 (fixed))
- Verified: https://github.com/advisories/GHSA-jh9g-8jqw-m2qx (GitHub-reviewed advisory GHSA-jh9g-8jqw-m2qx lists affected ranges: PyPI open-webui >=0 <=0.8.8)

Commands are suggestions: review each one before running it.

Loading voting…