Open WebUI Has Stored Cross-Site Scripting in SVG Renderer
CVE-2026-45346GHSA-r29h-37fj-x2w6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.6.31), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm open-webui
- Affected
- < 0.6.31
- Fixed in
- 0.6.31
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r29h-37fj-x2w6 lists affected ranges: npm open-webui >=0 <0.6.31 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r29h-37fj-x2w6 lists affected ranges: npm open-webui >=0 <0.6.31
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-45346: 0.17% estimated exploitation activity in the next 30 days; percentile 5.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary There is a Cross-Site Scripting vulnerability in Open WebUI SVG renderer implementation. Details It is possible permanently save any HTML/JavaScript code in the application, which can be then executed in the context of the application domain. This behaviour can be used to extract and steal sensitive data from the application, manipulate DOM tree or being used in complex client-side attacks. Detailed step-by-step instruction provided below. Please keep me updated about assigned CVE identifier. I'd like to be credited as: Jakub Żoczek [Securitum] PoC Steps to reproduce: To reproduce this vulnerability you need to: 1. Login to Open WebUI 2. Start new conversation / thread 3. Use prompt: "Hey. Can you draw me a green circle using SVG ?" 4. SVG image should be generated. 5. Now it's possible to edit the code by simply clicking on it and adding additional code. Add payload <img src=a onerror=alert(document.domain) 6. The whole code should look like this: <img width="1249" alt="AI…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r29h-37fj-x2w6
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-r29h-37fj-x2w6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45346 Advisory: Open WebUI Has Stored Cross-Site Scripting in SVG Renderer IDs: CVE-2026-45346, GHSA-r29h-37fj-x2w6 Record: https://patchnext.com/advisories/cve-2026-45346 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.6.31. A vendor fix does not mean a deployment is fixed. ## Affected components - npm open-webui: affected < 0.6.31; fixed in 0.6.31 ## Suggested inspection (read-only) - `npm ls open-webui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r29h-37fj-x2w6 (OSV record GHSA-r29h-37fj-x2w6 lists affected ranges: npm open-webui >=0 <0.6.31 (fixed)) - Verified: https://github.com/advisories/GHSA-r29h-37fj-x2w6 (GitHub-reviewed advisory GHSA-r29h-37fj-x2w6 lists affected ranges: npm open-webui >=0 <0.6.31) Commands are suggestions: review each one before running it.
Loading voting…