Open WebUI's API key endpoint restrictions bypassed via x-api-key header — full message processing on restricted endpoints
CVE-2026-45339GHSA-57q6-fvp4-pqmm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webu 0.9.0; open-webui 0.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webu
- Affected
- <= 0.8.12
- Fixed in
- 0.9.0
PyPI open-webui
- Affected
- < 0.9.0
- Fixed in
- 0.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-57q6-fvp4-pqmm lists affected ranges: PyPI open-webu >=0 <0.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-3543 lists affected ranges: PyPI open-webui >=0 <0.9.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-57q6-fvp4-pqmm lists affected ranges: PyPI open-webu >=0 <=0.8.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-57q6-fvp4-pqmm lists affected ranges: PyPI open-webui >=0 <0.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-57q6-fvp4-pqmm lists affected ranges: PyPI open-webui >=0 <0.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-45339: 0.31% estimated exploitation activity in the next 30 days; percentile 23.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Open WebUI allows admins to restrict which API endpoints an API key can access. When an API key is restricted from `/api/v1/messages`, requests using the `Authorization: Bearer sk-...` header are correctly blocked with 403. However, the same key sent via the `x-api-key` header bypasses the restriction entirely — the request is authenticated, the model is invoked, and a full response is returned.
Details Open WebUI's Anthropic-compatible API path accepts authentication via `x-api-key` header (standard for the Anthropic API). The endpoint restriction check only applies to keys presented via the `Authorization` header. When the same `sk-...` key is supplied in `x-api-key`, the restriction check is skipped but the key is still valid for authentication. This means any API key, regardless of its configured endpoint restrictions, can access any API endpoint by simply using `x-api-key` instead of `Authorization`.
PoC Verified against Open WebUI v0.8.11. Setup:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-57q6-fvp4-pqmm
- Revision 4 · amended ·
Amended from ghsa record GHSA-57q6-fvp4-pqmm
- Revision 3 · amended ·
Amended from ghsa record GHSA-57q6-fvp4-pqmm
- Revision 2 · amended ·
Amended from osv record PYSEC-2026-3543
- Revision 1 · created ·
Published from osv record GHSA-57q6-fvp4-pqmm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45339 Advisory: Open WebUI's API key endpoint restrictions bypassed via `x-api-key` header — full message processing on restricted endpoints IDs: CVE-2026-45339, GHSA-57q6-fvp4-pqmm Record: https://patchnext.com/advisories/cve-2026-45339 (revision 5, source checked 4 Nov 2026, 06:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webu 0.9.0; open-webui 0.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webu: affected <= 0.8.12; fixed in 0.9.0 - PyPI open-webui: affected < 0.9.0; fixed in 0.9.0 ## Suggested inspection (read-only) - `python -m pip show open-webu`: prints the installed version. Run with the environment that serves production active. - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webu, open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-57q6-fvp4-pqmm (OSV record GHSA-57q6-fvp4-pqmm lists affected ranges: PyPI open-webu >=0 <0.9.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-3543 (OSV record PYSEC-2026-3543 lists affected ranges: PyPI open-webui >=0 <0.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-57q6-fvp4-pqmm (GitHub-reviewed advisory GHSA-57q6-fvp4-pqmm lists affected ranges: PyPI open-webu >=0 <=0.8.12) - Verified: https://github.com/advisories/GHSA-57q6-fvp4-pqmm (GitHub-reviewed advisory GHSA-57q6-fvp4-pqmm lists affected ranges: PyPI open-webui >=0 <0.9.0) - Verified: https://osv.dev/vulnerability/GHSA-57q6-fvp4-pqmm (OSV record GHSA-57q6-fvp4-pqmm lists affected ranges: PyPI open-webui >=0 <0.9.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…