Skip to content

← Actionable
High, CVSS 7.6amended

Better Auth: Device authorization approve and deny accept any authenticated session while the user code is pending

CVE-2026-45337GHSA-cq3f-vc6p-68fh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.6.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm better-auth

    Affected
    >= 1.6.0, < 1.6.11
    Fixed in
    1.6.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-45337: 0.21% estimated exploitation activity in the next 30 days; percentile 11.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Am I affected? You are affected if all of the following are true: - You use better-auth at a version = 1.6.0, < 1.6.11. - The deviceAuthorization plugin is enabled in your auth config (deviceAuthorization() in your plugins array). - A third party can observe a pending user code before the legitimate user completes verification. The standard device-flow UX displays user codes to humans, so realistic exposure includes shoulder-surfing, screen-share, voice or video calls, support-chat transcripts, referrer headers, and shared logs. If your application does not enable the deviceAuthorization plugin, you are not affected. Fix: 1. Upgrade to better-auth@1.6.11 or later. 2. If you cannot upgrade, see workarounds below. Summary Better Auth's deviceAuthorization plugin treated any authenticated session as the owner of any pending device code. The ownership gate on POST /device/approve and POST /device/deny short-circuited whenever the row's userId was unset, and the GET /device verification…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cq3f-vc6p-68fh

  2. Revision 1 · created ·

    Published from osv record GHSA-cq3f-vc6p-68fh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45337

Advisory: Better Auth: Device authorization approve and deny accept any authenticated session while the user code is pending
IDs: CVE-2026-45337, GHSA-cq3f-vc6p-68fh
Record: https://patchnext.com/advisories/cve-2026-45337 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: better-auth 1.6.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm better-auth: affected >= 1.6.0, < 1.6.11; fixed in 1.6.11

## Suggested inspection (read-only)
- `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on better-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cq3f-vc6p-68fh (OSV record GHSA-cq3f-vc6p-68fh lists affected ranges: npm better-auth >=1.6.0 <1.6.11 (fixed))
- Verified: https://github.com/advisories/GHSA-cq3f-vc6p-68fh (GitHub-reviewed advisory GHSA-cq3f-vc6p-68fh lists affected ranges: npm better-auth >=1.6.0 <1.6.11)

Commands are suggestions: review each one before running it.

Loading voting…