Skip to content

← Actionable
Medium, CVSS 5.3

Kirby CMS's content locks disclose IDs and emails of inaccessible users from users.access/list permissions

CVE-2026-45334GHSA-39vq-49qm-r2mc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 5.4.1, 4.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    <= 4.9.0>= 5.0.0, <= 5.4.0
    Fixed in
    4.9.1, 5.4.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-45334: 0.36% estimated exploitation activity in the next 30 days; percentile 30.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR This vulnerability affects all Kirby sites that restrict the visibility of users for certain roles via the users.access or users.list permissions. A site is affected if users of a particular role are not allowed to see other users in the Panel, for example because the role's blueprint sets users.access: false or users.list: false as permission for the authenticated user role and/or as option for the target user role. A Kirby site is not affected if all authenticated Panel users are permitted to access and list other users. The vulnerability can only be exploited by authenticated users. --- Introduction Missing authorization allows authenticated users to gain access to information they are not intended to see. The effects of missing authorization can include unauthorized access to sensitive information as well as unauthorized changes to content or system information. Affected components Kirby's user permissions control which user role is allowed to perform specific actions or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-39vq-49qm-r2mc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45334

Advisory: Kirby CMS's content locks disclose IDs and emails of inaccessible users from `users.access/list` permissions
IDs: CVE-2026-45334, GHSA-39vq-49qm-r2mc
Record: https://patchnext.com/advisories/cve-2026-45334 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 5.4.1, 4.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected <= 4.9.0; >= 5.0.0, <= 5.4.0; fixed in 4.9.1, 5.4.1

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-39vq-49qm-r2mc (GitHub-reviewed advisory GHSA-39vq-49qm-r2mc lists affected ranges: Packagist getkirby/cms >=0 =5.0.0 <=5.4.0)

Commands are suggestions: review each one before running it.

Loading voting…