Open WebUI has a full SSRF Vulnerability in the RAG Web Search Feature
CVE-2026-45331GHSA-4v7r-f4w8-8972
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webui
- Affected
- <= 0.8.12
- Fixed in
- 0.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4v7r-f4w8-8972 lists affected ranges: PyPI open-webui >=0 <0.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4v7r-f4w8-8972 lists affected ranges: PyPI open-webui >=0 <=0.8.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-45331: 0.29% estimated exploitation activity in the next 30 days; percentile 21.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
SSRF Bypass via IPv6/IPv4-mapped IPv6/IPv4-reserved-ranges in validateurl() Summary validateurl() in backend/openwebui/retrieval/web/utils.py calls validators.ipv6(ip, private=True), but the validators library does NOT implement the private keyword for IPv6 — the call raises a ValidationError (which is falsy in a boolean context), so every IPv6 address passes the filter. In addition, IPv4-mapped IPv6 (::ffff:10.0.0.1) bypasses the IPv4 check entirely, and several reserved IPv4 ranges (0.0.0.0/8, 100.64.0.0/10, 192.0.0.0/24, etc.) are not blocked. The vulnerability has existed since the validateurl() function was introduced and was NOT actually fixed by GHSA-c6xv-rcvw-v685 / CVE-2025-65958 despite that patch's intent. It affects every endpoint that calls validateurl(), including /api/v1/retrieval/process/web, /api/v1/images/edit, and others. Affected code backend/openwebui/retrieval/web/utils.py validateurl(): Proof of concept End-to-end exploit: Impact Any authenticated user can…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4v7r-f4w8-8972
- Revision 1 · created ·
Published from osv record GHSA-4v7r-f4w8-8972
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45331 Advisory: Open WebUI has a full SSRF Vulnerability in the RAG Web Search Feature IDs: CVE-2026-45331, GHSA-4v7r-f4w8-8972 Record: https://patchnext.com/advisories/cve-2026-45331 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webui: affected <= 0.8.12; fixed in 0.9.0 ## Suggested inspection (read-only) - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4v7r-f4w8-8972 (OSV record GHSA-4v7r-f4w8-8972 lists affected ranges: PyPI open-webui >=0 <0.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4v7r-f4w8-8972 (GitHub-reviewed advisory GHSA-4v7r-f4w8-8972 lists affected ranges: PyPI open-webui >=0 <=0.8.12) Commands are suggestions: review each one before running it.
Loading voting…