Skip to content

← Actionable
Medium, CVSS 4.6amended

Open WebUI Vulnerable to Cross-Site Request Forgery (CSRF) via Image URL Manipulation

CVE-2026-45317GHSA-j6w6-986j-2m2m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:L
EPSS
  • CVE-2026-45317: 0.17% estimated exploitation activity in the next 30 days; percentile 5.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An application-wide Cross-Site Request Forgery (CSRF) vulnerability was found Open-WebUl's image uploading functionality. An attacker can set an image URL to a malicious endpoint, allowing them to perform actions on behalf of a victim user. Any authenticated user can exploit this vulnerability, and any user who views the compromised image (e.g., a profile picture) will unknowingly send a GET request to the attacker-controlled URL. This can lead to cookie theft, denial of service (DoS), or other malicious actions. This can be exploited in various locations, including: • Profile picture • Model picture • Hidden images in shared chats • Images within shared notes Details Vulnerable Code: This appears to occur in most locations where images can be uploaded/rendered. Here are found sinks: Profile Image in chat • Note: rendering profile picture in chat • Location:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j6w6-986j-2m2m

  2. Revision 1 · created ·

    Published from osv record GHSA-j6w6-986j-2m2m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45317

Advisory: Open WebUI Vulnerable to Cross-Site Request Forgery (CSRF) via Image URL Manipulation
IDs: CVE-2026-45317, GHSA-j6w6-986j-2m2m
Record: https://patchnext.com/advisories/cve-2026-45317 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected <= 0.9.2; fixed in 0.9.3

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j6w6-986j-2m2m (OSV record GHSA-j6w6-986j-2m2m lists affected ranges: PyPI open-webui >=0 <0.9.3 (fixed))
- Verified: https://github.com/advisories/GHSA-j6w6-986j-2m2m (GitHub-reviewed advisory GHSA-j6w6-986j-2m2m lists affected ranges: PyPI open-webui >=0 <=0.9.2)

Commands are suggestions: review each one before running it.

Loading voting…