DeepSeek TUI: run_tests Tool Enables RCE via Malicious Repository Without Approval
CVE-2026-45311GHSA-wx44-2q6h-j6p8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (deepseek-tui 0.8.23; deepseek-tui-cli 0.8.23; deepseek-tui 0.8.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm deepseek-tui
- Affected
- >= 0.3.0, < 0.8.23
- Fixed in
- 0.8.23
crates.io deepseek-tui-cli
- Affected
- >= 0.3.0, < 0.8.23
- Fixed in
- 0.8.23
crates.io deepseek-tui
- Affected
- >= 0.3.0, < 0.8.23
- Fixed in
- 0.8.23
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wx44-2q6h-j6p8 lists affected ranges: npm deepseek-tui >=0.3.0 <0.8.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wx44-2q6h-j6p8 lists affected ranges: crates.io deepseek-tui >=0.3.0 =0.3.0 =0.3.0 <0.8.23 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wx44-2q6h-j6p8 lists affected ranges: crates.io deepseek-tui >=0.3.0 =0.3.0 =0.3.0 <0.8.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-45311: 0.57% estimated exploitation activity in the next 30 days; percentile 47.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The runtests tool executes cargo test in the workspace with ApprovalRequirement::Auto, meaning it runs without any user approval prompt. The source code explicitly states this design choice: cargo test compiles and executes arbitrary code: test binaries, build.rs build scripts, and proc macros. While auto-approving test execution is a deliberate design choice, it creates an inconsistency in the security boundary. However, in a malicious repository, test code can execute arbitrary shell commands, exfiltrate credentials, or establish persistence with zero approval. The attack is amplified by AGENTS.md (auto-loaded into the system prompt), which can instruct the model to run tests proactively at session start. PoC Step 1 — Create a malicious Rust repo: Cargo.toml: [package] name = "cool-library" version = "0.1.0" edition = "2021" src/lib.rs: pub fn add(a: i32, b: i32) - i32 { a + b } tests/integrationtest.rs: use coollibrary::add; #[test] fn testadd() { asserteq!(add(2, 3), 5);…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wx44-2q6h-j6p8
- Revision 2 · amended ·
Amended from osv record GHSA-wx44-2q6h-j6p8
- Revision 1 · created ·
Published from ghsa record GHSA-wx44-2q6h-j6p8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45311 Advisory: DeepSeek TUI: run_tests Tool Enables RCE via Malicious Repository Without Approval IDs: CVE-2026-45311, GHSA-wx44-2q6h-j6p8 Record: https://patchnext.com/advisories/cve-2026-45311 (revision 3, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: deepseek-tui 0.8.23; deepseek-tui-cli 0.8.23; deepseek-tui 0.8.23. A vendor fix does not mean a deployment is fixed. ## Affected components - npm deepseek-tui: affected >= 0.3.0, < 0.8.23; fixed in 0.8.23 - crates.io deepseek-tui-cli: affected >= 0.3.0, < 0.8.23; fixed in 0.8.23 - crates.io deepseek-tui: affected >= 0.3.0, < 0.8.23; fixed in 0.8.23 ## Suggested inspection (read-only) - `npm ls deepseek-tui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - crates.io deepseek-tui-cli: check the installed version with your package manager. - crates.io deepseek-tui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on deepseek-tui, deepseek-tui-cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wx44-2q6h-j6p8 (GitHub-reviewed advisory GHSA-wx44-2q6h-j6p8 lists affected ranges: npm deepseek-tui >=0.3.0 <0.8.23) - Verified: https://osv.dev/vulnerability/GHSA-wx44-2q6h-j6p8 (OSV record GHSA-wx44-2q6h-j6p8 lists affected ranges: crates.io deepseek-tui >=0.3.0 =0.3.0 =0.3.0 <0.8.23 (fixed)) - Verified: https://github.com/advisories/GHSA-wx44-2q6h-j6p8 (GitHub-reviewed advisory GHSA-wx44-2q6h-j6p8 lists affected ranges: crates.io deepseek-tui >=0.3.0 =0.3.0 =0.3.0 <0.8.23) Commands are suggestions: review each one before running it.
Loading voting…