Skip to content

← Actionable
High, CVSS 7.4amended

DeepSeek TUI has SSRF via HTTP Redirect Bypass in fetch_url Tool

CVE-2026-45310GHSA-96ff-gc8g-wpvg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (deepseek-tui 0.8.22; deepseek-tui-cli 0.8.22; deepseek-tui 0.8.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-45310: 0.28% estimated exploitation activity in the next 30 days; percentile 20.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The fetchurl tool validates the initial URL's resolved IP address against a restricted-IP blocklist (isrestrictedip()) to prevent SSRF attacks against internal services (cloud metadata endpoints, localhost, private networks). However, the HTTP client (reqwest) is configured to automatically follow up to 5 redirects (reqwest::redirect::Policy::limited(5)) without re-validating the redirect target against the same SSRF protections. PoC Step 1 — Baseline: Confirm fetchurl blocks direct requests to restricted IPs. Step 2 — SSRF bypass via redirect: Fetch a public URL that redirects to the restricted IP. Expected result: The error message says "connection refused" or "request failed: connect error" — NOT "restricted address." This proves the SSRF filter was bypassed; the connection failed only because 169.254.169.254 is unreachable from a non-cloud machine. Observed result: fetchurl followed the 302 redirect and attempted to connect to 169.254.169.254. The error was a TCP-level…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-96ff-gc8g-wpvg

  2. Revision 1 · created ·

    Published from osv record GHSA-96ff-gc8g-wpvg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45310

Advisory: DeepSeek TUI has SSRF via HTTP Redirect Bypass in fetch_url Tool
IDs: CVE-2026-45310, GHSA-96ff-gc8g-wpvg
Record: https://patchnext.com/advisories/cve-2026-45310 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: deepseek-tui 0.8.22; deepseek-tui-cli 0.8.22; deepseek-tui 0.8.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm deepseek-tui: affected < 0.8.22; fixed in 0.8.22
- crates.io deepseek-tui-cli: affected < 0.8.22; fixed in 0.8.22
- crates.io deepseek-tui: affected < 0.8.22; fixed in 0.8.22

## Suggested inspection (read-only)
- `npm ls deepseek-tui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- crates.io deepseek-tui-cli: check the installed version with your package manager.
- crates.io deepseek-tui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on deepseek-tui, deepseek-tui-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-96ff-gc8g-wpvg (OSV record GHSA-96ff-gc8g-wpvg lists affected ranges: crates.io deepseek-tui >=0 =0 =0 <0.8.22 (fixed))
- Verified: https://github.com/advisories/GHSA-96ff-gc8g-wpvg (GitHub-reviewed advisory GHSA-96ff-gc8g-wpvg lists affected ranges: crates.io deepseek-tui >=0 =0 =0 <0.8.22)

Commands are suggestions: review each one before running it.

Loading voting…