Skip to content

← Actionable
Medium, CVSS 6.9amended

AsyncSSH AuthorizedKeysFile %u path traversal allows attacker-selected authorized keys to authenticate a traversal username

CVE-2026-45309GHSA-g794-3fmp-753h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (asyncssh 2.23.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI asyncssh

    Affected
    >= 2.22.0, <= 2.22.0
    Fixed in
    2.23.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-45309: 0.59% estimated exploitation activity in the next 30 days; percentile 48.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary AsyncSSH 2.22.0 expands the OpenSSH-compatible AuthorizedKeysFile %u token with the raw SSH username during pre-authentication server config reload. A server configured with a documented per-user key pattern such as AuthorizedKeysFile authorizedkeys/%u can be made to read an authorized-keys file outside the intended directory when the SSH username contains path traversal segments. If the attacker can place or reference a readable authorized-keys-format file containing their public key, the attacker can authenticate over SSH as the traversal username. Affected Product - Package: asyncssh - Ecosystem: pip - Affected versions: confirmed on 2.22.0; exact lower bound not finalized - Tested version: 2.22.0 - Audit commit/tag: tag v2.22.0, commit af5a81e669633d83d535163f93b6bf3f957c9238 - PyPI sdist SHA256: c3ce72b01be4f97b40e62844dd384227e5ff5a401a3793007c42f86a5c8eb537 Vulnerability Details - CWE: CWE-22: Improper Limitation of a Pathname to a Restricted Directory - Component:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g794-3fmp-753h

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-g794-3fmp-753h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45309

Advisory: AsyncSSH `AuthorizedKeysFile %u` path traversal allows attacker-selected authorized keys to authenticate a traversal username
IDs: CVE-2026-45309, GHSA-g794-3fmp-753h
Record: https://patchnext.com/advisories/cve-2026-45309 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: asyncssh 2.23.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI asyncssh: affected >= 2.22.0, <= 2.22.0; fixed in 2.23.0

## Suggested inspection (read-only)
- `python -m pip show asyncssh`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on asyncssh.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g794-3fmp-753h (OSV record GHSA-g794-3fmp-753h lists affected ranges: PyPI asyncssh >=2.22.0 <2.23.0 (fixed))
- Verified: https://github.com/advisories/GHSA-g794-3fmp-753h (GitHub-reviewed advisory GHSA-g794-3fmp-753h lists affected ranges: PyPI asyncssh >=2.22.0 <=2.22.0)

Commands are suggestions: review each one before running it.

Loading voting…