Skip to content

← Actionable
High, CVSS 7.7amended

Open WebUI has stored XSS via the HTML renedering view

CVE-2026-45303GHSA-4vrc-m9ch-6m3r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.6.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-45303: 0.22% estimated exploitation activity in the next 30 days; percentile 13.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Through the HTML rendering view, scripts can be injected and executed. The finding resulted from a penetration test for a customer. It is suspected that the root cause of the issue lies within the core of Open WebUI, which is why it is being reported as a security issue here. Tested on Open WebUI 0.5.4. Details The frontend provides a function to visualize the HTML content of a current chat. The content is embedded in an iFrame with the following sandbox directive: sandbox="allow-scripts allow-forms allow-same-origin" This means that the content is placed in a sandbox but with permission to execute scripts and access the parent’s data (e.g., local storage). As a result, only a few functions are restricted (e.g., displaying an alert box), but in effect, the sandbox attribute is largely nullified. PoC If an HTML document containing a script is included in the chat, this script will be embedded in the view and executed. This can be achieved with a message like the following: By…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4vrc-m9ch-6m3r

  2. Revision 1 · created ·

    Published from osv record GHSA-4vrc-m9ch-6m3r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45303

Advisory: Open WebUI has stored XSS via the HTML renedering view
IDs: CVE-2026-45303, GHSA-4vrc-m9ch-6m3r
Record: https://patchnext.com/advisories/cve-2026-45303 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.6.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected < 0.6.5; fixed in 0.6.5

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4vrc-m9ch-6m3r (OSV record GHSA-4vrc-m9ch-6m3r lists affected ranges: PyPI open-webui >=0 <0.6.5 (fixed))
- Verified: https://github.com/advisories/GHSA-4vrc-m9ch-6m3r (GitHub-reviewed advisory GHSA-4vrc-m9ch-6m3r lists affected ranges: PyPI open-webui >=0 <0.6.5)

Commands are suggestions: review each one before running it.

Loading voting…