WordPress Coding Standards (WordPressCS) contains an arbitrary code execution vulnerability
CVE-2026-45293GHSA-3pwp-g2mj-5p3v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wp-coding-standards/wpcs 3.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist wp-coding-standards/wpcs
- Affected
- >= 0.14.1, < 3.4.1
- Fixed in
- 3.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3pwp-g2mj-5p3v lists affected ranges: Packagist wp-coding-standards/wpcs >=0.14.1 <3.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3pwp-g2mj-5p3v lists affected ranges: Packagist wp-coding-standards/wpcs >=0.14.1 <3.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-45293: 0.25% estimated exploitation activity in the next 30 days; percentile 16.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact WordPress Coding Standards (WordPressCS) versions before 3.4.1 contain an arbitrary code execution vulnerability in the WordPress.WP.EnqueuedResourceParameters sniff. As a result, running PHPCS with WordPressCS over untrusted PHP code, for example, in a CI pipeline that lints pull requests, or on a developer machine reviewing third-party code, could lead to arbitrary command execution on the scanning host. This affects users of the WordPress and WordPress-Extra rulesets. The WordPress-Core ruleset and the WordPress-Docs ruleset are not affected. The vulnerability happens when the sniff checks whether the $var argument passed to functions such as wpenqueuescript() or wpregisterscript() evaluates to a falsy value. The sniff's isfalsy() method reconstructed the argument and ran it through eval(). Because of this, a maliciously crafted $ver argument such as 'system'('id') would be executed during the scan. Patches This issue has been fixed in WordPressCS 3.4.1. We recommend all…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3pwp-g2mj-5p3v
- Revision 1 · created ·
Published from osv record GHSA-3pwp-g2mj-5p3v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45293 Advisory: WordPress Coding Standards (WordPressCS) contains an arbitrary code execution vulnerability IDs: CVE-2026-45293, GHSA-3pwp-g2mj-5p3v Record: https://patchnext.com/advisories/cve-2026-45293 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wp-coding-standards/wpcs 3.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist wp-coding-standards/wpcs: affected >= 0.14.1, < 3.4.1; fixed in 3.4.1 ## Suggested inspection (read-only) - Packagist wp-coding-standards/wpcs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wp-coding-standards/wpcs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3pwp-g2mj-5p3v (OSV record GHSA-3pwp-g2mj-5p3v lists affected ranges: Packagist wp-coding-standards/wpcs >=0.14.1 <3.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-3pwp-g2mj-5p3v (GitHub-reviewed advisory GHSA-3pwp-g2mj-5p3v lists affected ranges: Packagist wp-coding-standards/wpcs >=0.14.1 <3.4.1) Commands are suggestions: review each one before running it.
Loading voting…