FacturaScripts: Authenticated SQL injection in the FacturaScripts REST API filter parameter via parenthesis bypass in Where::sqlColumn
CVE-2026-45262GHSA-5qmh-x653-g8qj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (facturascripts/facturascripts 2026.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist facturascripts/facturascripts
- Affected
- < 2026.2
- Fixed in
- 2026.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5qmh-x653-g8qj lists affected ranges: Packagist facturascripts/facturascripts >=0 <=2026.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5qmh-x653-g8qj lists affected ranges: Packagist facturascripts/facturascripts >=0 <2026.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary > Live PoC verified 2026-04-30 against a stock FacturaScripts master at `127.0.0.1:8081`. A scoped `ApiKey` with `fullaccess=0` and an `ApiAccess` row granting `allowget=1` on the `clientes` resource only (no other rights, no UI session, no admin) issued one `GET /api/3/clientes?filter[(0)UNION%20SELECT%20...]=` request and the response body contained the raw bcrypt hash of the admin user's password (`$2y$12$sLfA/XCqnjqLmYJwK.2V7eUHrHTHcQfkTYYfs1.lxX3OHrsmmkMGO`) and the admin's `logkey` cookie value. The leaked `logkey` was injected into a fresh cookie jar and `GET /AdminPlugins` returned 200 with the admin plugin management UI. End-to-end account takeover from a read-only token with no CSRF, no second factor, no rate-limit interaction beyond the default 5-incident IP throttle. `Core/Where.php::sqlColumn()` exempts any field name that contains both `(` and `)` from identifier escaping. The two API filter builders (`APIModel::getWhereValues` and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-5qmh-x653-g8qj
- Revision 2 · amended ·
Amended from ghsa record GHSA-5qmh-x653-g8qj
- Revision 1 · created ·
Published from ghsa record GHSA-5qmh-x653-g8qj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45262 Advisory: FacturaScripts: Authenticated SQL injection in the FacturaScripts REST API filter parameter via parenthesis bypass in `Where::sqlColumn` IDs: CVE-2026-45262, GHSA-5qmh-x653-g8qj Record: https://patchnext.com/advisories/cve-2026-45262 (revision 3, source checked 3 Nov 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: facturascripts/facturascripts 2026.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist facturascripts/facturascripts: affected < 2026.2; fixed in 2026.2 ## Suggested inspection (read-only) - Packagist facturascripts/facturascripts: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on facturascripts/facturascripts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5qmh-x653-g8qj (GitHub-reviewed advisory GHSA-5qmh-x653-g8qj lists affected ranges: Packagist facturascripts/facturascripts >=0 <=2026.1) - Verified: https://osv.dev/vulnerability/GHSA-5qmh-x653-g8qj (OSV record GHSA-5qmh-x653-g8qj lists affected ranges: Packagist facturascripts/facturascripts >=0 <2026.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…