Summarize contains a path traversal vulnerability
CVE-2026-45242GHSA-8jr4-6r33-phwm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@steipete/summarize 0.15.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.15.0
- Fixed in
- 0.15.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8jr4-6r33-phwm lists affected ranges: npm @steipete/summarize >=0 <0.15.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8jr4-6r33-phwm lists affected ranges: npm @steipete/summarize >=0 <0.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-45242: 0.40% estimated exploitation activity in the next 30 days; percentile 33.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summarize prior to 0.15.0 contains a path traversal vulnerability in the /v1/summarize daemon endpoint that allows authenticated callers to write files to arbitrary directories by supplying an absolute path or directory traversal sequence in the slidesDir request parameter. Attackers can exploit this to write slide.png and slides.json files to any writable directory and subsequently delete matching files at the specified location through repeat extraction.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8jr4-6r33-phwm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8jr4-6r33-phwm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45242 Advisory: Summarize contains a path traversal vulnerability IDs: CVE-2026-45242, GHSA-8jr4-6r33-phwm Record: https://patchnext.com/advisories/cve-2026-45242 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @steipete/summarize 0.15.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @steipete/summarize: affected < 0.15.0; fixed in 0.15.0 ## Suggested inspection (read-only) - `npm ls @steipete/summarize --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @steipete/summarize. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8jr4-6r33-phwm (OSV record GHSA-8jr4-6r33-phwm lists affected ranges: npm @steipete/summarize >=0 <0.15.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8jr4-6r33-phwm (GitHub-reviewed advisory GHSA-8jr4-6r33-phwm lists affected ranges: npm @steipete/summarize >=0 <0.15.0) Commands are suggestions: review each one before running it.
Loading voting…