Skip to content

← Actionable
Medium, CVSS 6.9amended

@steipete/summarize allows local attackers to read bearer tokens and API credentials stored in ~/.summarize/daemon.json

CVE-2026-45222GHSA-qp7v-gjgg-4mj6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@steipete/summarize 0.15.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-45222: 0.15% estimated exploitation activity in the next 30 days; percentile 4.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summarize versions through 0.14.1, fixed in commit 0cfb0fb, creates the daemon configuration directory and file with default filesystem permissions that may be world-readable on Unix-like systems, allowing local attackers to read bearer tokens and API credentials stored in ~/.summarize/daemon.json. A local attacker can exploit these permissive permissions to read the daemon bearer token and persisted provider credentials, enabling unauthorized access to the daemon or recovery of sensitive API keys.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qp7v-gjgg-4mj6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qp7v-gjgg-4mj6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45222

Advisory: @steipete/summarize allows local attackers to read bearer tokens and API credentials stored in ~/.summarize/daemon.json
IDs: CVE-2026-45222, GHSA-qp7v-gjgg-4mj6
Record: https://patchnext.com/advisories/cve-2026-45222 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @steipete/summarize 0.15.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @steipete/summarize: affected < 0.15.0; fixed in 0.15.0

## Suggested inspection (read-only)
- `npm ls @steipete/summarize --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @steipete/summarize.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qp7v-gjgg-4mj6 (OSV record GHSA-qp7v-gjgg-4mj6 lists affected ranges: npm @steipete/summarize >=0 <0.15.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qp7v-gjgg-4mj6 (GitHub-reviewed advisory GHSA-qp7v-gjgg-4mj6 lists affected ranges: npm @steipete/summarize >=0 <0.15.0)

Commands are suggestions: review each one before running it.

Loading voting…