Skip to content

← Actionable
Medium, CVSS 6.5amended

Apache Airflow: Incomplete redaction allowlist exposes secrets in Connection extra to read-permitted users

CVE-2026-45192GHSA-2883-wwh7-x57v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-45192: 0.43% estimated exploitation activity in the next 30 days; percentile 36.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A bug in the GET /api/v2/connections/{connectionid} REST API endpoint in Apache Airflow allowed an authenticated UI/API user with Connection-read permission to retrieve secrets stored in a Connection's extra JSON blob under field names not present in the redaction allowlist (DEFAULTSENSITIVEFIELDS) — for example, official Slack-provider credential field names were returned in plaintext. Affects deployments that store credentials in Connection extra blobs and grant Connection-read access to multiple users. Users are advised to upgrade to apache-airflow 3.2.2 or later. As a defense-in-depth mitigation, deployment operators can store sensitive credential values in a secret-backend rather than inlined into the Connection's extra field.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2883-wwh7-x57v

  2. Revision 1 · created ·

    Published from osv record GHSA-2883-wwh7-x57v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45192

Advisory: Apache Airflow: Incomplete redaction allowlist exposes secrets in Connection `extra` to read-permitted users
IDs: CVE-2026-45192, GHSA-2883-wwh7-x57v
Record: https://patchnext.com/advisories/cve-2026-45192 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected < 3.2.2; fixed in 3.2.2

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2883-wwh7-x57v (OSV record GHSA-2883-wwh7-x57v lists affected ranges: PyPI apache-airflow >=0 <3.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-2883-wwh7-x57v (GitHub-reviewed advisory GHSA-2883-wwh7-x57v lists affected ranges: PyPI apache-airflow >=0 <3.2.2)

Commands are suggestions: review each one before running it.

Loading voting…