Skip to content

← Actionable
Medium, CVSS 6.5amended

brace-expansion: Large numeric range defeats documented max DoS protection

CVE-2026-45149GHSA-jxxr-4gwj-5jf2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (brace-expansion 5.0.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-45149: 0.30% estimated exploitation activity in the next 30 days; percentile 22.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The max option was being applied too late: When expanding a single large numeric range like {1..10000000}, the sequence generation loop generates all 10 million intermediate elements before the max limit is applied With max=10, the output is correctly limited to 10 items, but the process still allocates ~505 MB and spends ~800ms building the full intermediate array. Workaround Ensure the string to be expanded doesn't contain more values than the desired max item count.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jxxr-4gwj-5jf2

  2. Revision 1 · created ·

    Published from osv record GHSA-jxxr-4gwj-5jf2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45149

Advisory: brace-expansion: Large numeric range defeats documented `max` DoS protection
IDs: CVE-2026-45149, GHSA-jxxr-4gwj-5jf2
Record: https://patchnext.com/advisories/cve-2026-45149 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: brace-expansion 5.0.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm brace-expansion: affected >= 5.0.0, < 5.0.6; fixed in 5.0.6

## Suggested inspection (read-only)
- `npm ls brace-expansion --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on brace-expansion.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jxxr-4gwj-5jf2 (OSV record GHSA-jxxr-4gwj-5jf2 lists affected ranges: npm brace-expansion >=5.0.0 <5.0.6 (fixed))
- Verified: https://github.com/advisories/GHSA-jxxr-4gwj-5jf2 (GitHub-reviewed advisory GHSA-jxxr-4gwj-5jf2 lists affected ranges: npm brace-expansion >=5.0.0 <5.0.6)

Commands are suggestions: review each one before running it.

Loading voting…