CI4MS Fileeditor allows deletion and rename of critical application files due to missing extension allowlist on destructive operations
CVE-2026-45139GHSA-245j-xjvr-xvm5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ci4-cms-erp/ci4ms 0.31.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ci4-cms-erp/ci4ms
- Affected
- <= 0.31.8.0
- Fixed in
- 0.31.9.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-245j-xjvr-xvm5 lists affected ranges: Packagist ci4-cms-erp/ci4ms >=0 <=0.31.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2026-45139: 0.32% estimated exploitation activity in the next 30 days; percentile 25.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Fileeditor module enforces an extension allowlist (['css','js','html','txt','json','sql','md']) on content-write operations (saveFile, createFile), but two destructive endpoints — deleteFileOrFolder and renameFile — never validate the extension of the source path. A backend user with file-editor permissions can therefore unlink or rename any file inside the project root that is not explicitly listed in the small $hiddenItems blocklist. Critical framework files such as app/Config/Routes.php, app/Config/App.php, app/Config/Database.php, app/Config/Filters.php, public/index.php, and public/.htaccess all live outside that blocklist and can be destroyed, producing a persistent denial of service that requires filesystem-level redeployment to recover. Details Root cause: inconsistent application of the extension allowlist across Fileeditor operations in modules/Fileeditor/Controllers/Fileeditor.php. The class declares an allowlist used by content-write operations: saveFile (line…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-245j-xjvr-xvm5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45139 Advisory: CI4MS Fileeditor allows deletion and rename of critical application files due to missing extension allowlist on destructive operations IDs: CVE-2026-45139, GHSA-245j-xjvr-xvm5 Record: https://patchnext.com/advisories/cve-2026-45139 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ci4-cms-erp/ci4ms 0.31.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ci4-cms-erp/ci4ms: affected <= 0.31.8.0; fixed in 0.31.9.0 ## Suggested inspection (read-only) - Packagist ci4-cms-erp/ci4ms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ci4-cms-erp/ci4ms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-245j-xjvr-xvm5 (GitHub-reviewed advisory GHSA-245j-xjvr-xvm5 lists affected ranges: Packagist ci4-cms-erp/ci4ms >=0 <=0.31.8.0) Commands are suggestions: review each one before running it.
Loading voting…