Skip to content

← Actionable
High, CVSS 7.1amended

LangSmith SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning

CVE-2026-45134GHSA-3644-q5cj-c5c7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langsmith 0.6.0; langchain 0.3.30; langsmith 0.8.0; langchain-classic 1.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-45134: 0.20% estimated exploitation activity in the next 30 days; percentile 9.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description The LangSmith SDK's prompt pull methods (pullprompt / pullpromptcommit in Python, pullPrompt / pullPromptCommit in JS/TS) fetch and deserialize prompt manifests from the LangSmith Hub. These manifests may contain serialized LangChain objects and model configuration that affect runtime behavior. When pulling a public prompt by owner/name identifier, the manifest content is controlled by an external party, but prior versions of the SDK did not distinguish this from pulling a prompt within the caller's own organization. Prompt manifests can intentionally configure a model with a custom base URL, default headers, model name, or other constructor arguments. These are supported features, but they also mean the prompt contents should be treated as executable configuration rather than plain text. A prompt can also include serialized LangChain Runnable or PromptTemplate objects with attacker-controlled constructor kwargs, or secret references that, if secretsfromenv is enabled,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3644-q5cj-c5c7

  2. Revision 1 · created ·

    Published from osv record GHSA-3644-q5cj-c5c7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45134

Advisory: LangSmith SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning
IDs: CVE-2026-45134, GHSA-3644-q5cj-c5c7
Record: https://patchnext.com/advisories/cve-2026-45134 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langsmith 0.6.0; langchain 0.3.30; langsmith 0.8.0; langchain-classic 1.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm langsmith: affected < 0.6.0; fixed in 0.6.0
- PyPI langchain: affected < 0.3.30; fixed in 0.3.30
- PyPI langsmith: affected < 0.8.0; fixed in 0.8.0
- PyPI langchain-classic: affected < 1.0.7; fixed in 1.0.7

## Suggested inspection (read-only)
- `npm ls langsmith --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `python -m pip show langchain`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show langsmith`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show langchain-classic`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langsmith, langchain, langchain-classic.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3644-q5cj-c5c7 (OSV record GHSA-3644-q5cj-c5c7 lists affected ranges: PyPI langsmith >=0 =0 =0 =0 <0.3.30 (fixed))
- Verified: https://github.com/advisories/GHSA-3644-q5cj-c5c7 (GitHub-reviewed advisory GHSA-3644-q5cj-c5c7 lists affected ranges: PyPI langsmith >=0 =0 =0 =0 <0.3.30)

Commands are suggestions: review each one before running it.

Loading voting…