Skip to content

← Actionable
Low, CVSS 2.7

Symfony hardened the parser when handling untrusted input

CVE-2026-45133GHSA-c2p3-7m5p-cv8x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 8.0.12, 7.4.12, 6.4.40, 5.4.52; symfony/yaml 8.0.12, 7.4.12, 6.4.40, 5.4.52), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    < 5.4.52>= 6.0.0, < 6.4.40>= 7.0.0, < 7.4.12>= 8.0.0, < 8.0.12
    Fixed in
    8.0.12, 7.4.12, 6.4.40, 5.4.52
  • Packagist symfony/yaml

    Affected
    < 5.4.52>= 6.0.0, < 6.4.40>= 7.0.0, < 7.4.12>= 8.0.0, < 8.0.12
    Fixed in
    8.0.12, 7.4.12, 6.4.40, 5.4.52

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-45133: 0.63% estimated exploitation activity in the next 30 days; percentile 50.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Symfony\Component\Yaml\Parser is the entry point for parsing YAML strings into PHP values via Yaml::parse(). When the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. Resolution The Parser now tracks recursion depth in a shared ParserState object across both block-level and inline parsing, with a default limit of 128. The limit is configurable via a new $maxNestingLevel argument on Parser::construct(), Yaml::parse() and Yaml::parseFile(). The patch for this issue is available here for branch 5.4. Credits Symfony would like to thank Pietro Tirenna (Shielder) for reporting the issue and Nicolas Grekas for fixing it.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c2p3-7m5p-cv8x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45133

Advisory: Symfony hardened the parser when handling untrusted input
IDs: CVE-2026-45133, GHSA-c2p3-7m5p-cv8x
Record: https://patchnext.com/advisories/cve-2026-45133 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 8.0.12, 7.4.12, 6.4.40, 5.4.52; symfony/yaml 8.0.12, 7.4.12, 6.4.40, 5.4.52. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected < 5.4.52; >= 6.0.0, < 6.4.40; >= 7.0.0, < 7.4.12; >= 8.0.0, < 8.0.12; fixed in 8.0.12, 7.4.12, 6.4.40, 5.4.52
- Packagist symfony/yaml: affected < 5.4.52; >= 6.0.0, < 6.4.40; >= 7.0.0, < 7.4.12; >= 8.0.0, < 8.0.12; fixed in 8.0.12, 7.4.12, 6.4.40, 5.4.52

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/yaml: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/yaml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c2p3-7m5p-cv8x (GitHub-reviewed advisory GHSA-c2p3-7m5p-cv8x lists affected ranges: Packagist symfony/yaml >=0 =6.0.0 =7.0.0 =8.0.0 =0 =6.0.0 =7.0.0 =8.0.0 <8.0.12)

Commands are suggestions: review each one before running it.

Loading voting…