Skip to content

← Actionable
High, CVSS 7.5amended

Next.js has a Middleware / Proxy bypass in App Router applications via segment-prefetch routes - Incomplete Fix Follow-Up

CVE-2026-45109GHSA-26hh-7cqf-hhc6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.2.6, 15.5.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 15.2.0, < 15.5.18>= 16.0.0, < 16.2.6
    Fixed in
    15.5.18, 16.2.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-45109: 0.60% estimated exploitation activity in the next 30 days; percentile 48.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact It was found that the fix addressing CVE-2026-44575 did not apply to `middleware.ts` with Turbopack. Refer to CVE-2026-44575 for further details.

References - CVE CVE-2026-44575

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-26hh-7cqf-hhc6

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-26hh-7cqf-hhc6

  3. Revision 2 · amended ·

    Amended from ghsa record GHSA-26hh-7cqf-hhc6

  4. Revision 1 · created ·

    Published from osv record GHSA-26hh-7cqf-hhc6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45109

Advisory: Next.js has a Middleware / Proxy bypass in App Router applications via segment-prefetch routes - Incomplete Fix Follow-Up
IDs: CVE-2026-45109, GHSA-26hh-7cqf-hhc6
Record: https://patchnext.com/advisories/cve-2026-45109 (revision 4, source checked 4 Nov 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.2.6, 15.5.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 15.2.0, < 15.5.18; >= 16.0.0, < 16.2.6; fixed in 15.5.18, 16.2.6

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-26hh-7cqf-hhc6 (OSV record GHSA-26hh-7cqf-hhc6 lists affected ranges: npm next >=15.2.0 =16.0.0 <16.2.6 (fixed))
- Verified: https://github.com/advisories/GHSA-26hh-7cqf-hhc6 (GitHub-reviewed advisory GHSA-26hh-7cqf-hhc6 lists affected ranges: npm next >=15.2.0 =16.0.0 <16.2.6)

Commands are suggestions: review each one before running it.

Loading voting…