Decidim: Forms admin question editor lacks authorization
CVE-2026-45086GHSA-vq6j-hj8w-7v39
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim-demographics 0.32.0, 0.31.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems decidim-demographics
- Affected
- >= 0.31.0, < 0.31.5>= 0.32.0.rc1, < 0.32.0
- Fixed in
- 0.31.5, 0.32.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vq6j-hj8w-7v39 lists affected ranges: RubyGems decidim-demographics >=0.31.0 =0.32.0.rc1 <0.32.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-45086: 0.29% estimated exploitation activity in the next 30 days; percentile 22.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description A participant can load the demographics questionnaire admin editor and make changes. Technical description The demographics questionnaire editor should require admin access, but the route under /admin/demographics/questions renders the editor interface without checking whether the caller is an admin. A normal participant can load the page and see the live update form action, which proves the protected interface is reachable. Reproduction steps: Step 1. Sign in as a normal participant: Open http://localhost:3000/users/signin. Step 2. Request the admin-only editor directly. Open http://localhost:3000/admin/demographics/questions/editquestions in the same browser. Step 3. Add another question: <img width="1522" height="1174" alt="decidim-questions-01" src="https://github.com/user-attachments/assets/923f85d4-0e2f-4511-a9f3-a92f74dbf1d8" / Note that access was denied when attempting to see question responses or settings. Impact - Low-privilege users can access…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vq6j-hj8w-7v39
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45086 Advisory: Decidim: Forms admin question editor lacks authorization IDs: CVE-2026-45086, GHSA-vq6j-hj8w-7v39 Record: https://patchnext.com/advisories/cve-2026-45086 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: decidim-demographics 0.32.0, 0.31.5. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems decidim-demographics: affected >= 0.31.0, < 0.31.5; >= 0.32.0.rc1, < 0.32.0; fixed in 0.31.5, 0.32.0 ## Suggested inspection (read-only) - RubyGems decidim-demographics: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on decidim-demographics. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vq6j-hj8w-7v39 (GitHub-reviewed advisory GHSA-vq6j-hj8w-7v39 lists affected ranges: RubyGems decidim-demographics >=0.31.0 =0.32.0.rc1 <0.32.0) Commands are suggestions: review each one before running it.
Loading voting…