Skip to content

← Actionable
High, CVSS 8.1

Symfony has Unauthenticated PHP Object Deserialization in MonologBridge server:log Listener

CVE-2026-45077GHSA-m7v2-7gxm-vc2v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 8.0.12, 7.4.12, 6.4.40, 5.4.52; symfony/monolog-bridge 8.0.12, 7.4.12, 6.4.40, 5.4.52), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    < 5.4.52>= 6.0.0, < 6.4.40>= 7.0.0, < 7.4.12>= 8.0.0, < 8.0.12
    Fixed in
    8.0.12, 7.4.12, 6.4.40, 5.4.52
  • Packagist symfony/monolog-bridge

    Affected
    < 5.4.52>= 6.0.0, < 6.4.40>= 7.0.0, < 7.4.12>= 8.0.0, < 8.0.12
    Fixed in
    8.0.12, 7.4.12, 6.4.40, 5.4.52

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-m7v2-7gxm-vc2v lists affected ranges: Packagist symfony/monolog-bridge >=0 =6.0.0 =7.0.0 =8.0.0 =0 =6.0.0 =7.0.0 =8.0.0 <8.0.12

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-45077: 0.67% estimated exploitation activity in the next 30 days; percentile 51.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Symfony\Bridge\Monolog\Command\ServerLogCommand (the server:log console command) is a development-time helper that opens a TCP listener and displays log records pushed to it by the application's logging pipeline. Two unsafe defaults combine into a remotely reachable PHP object-deserialization sink: 1. The listener binds to 0.0.0.0:9911 by default; it accepts connections on every interface, not only loopback. 2. Each received frame is processed as unserialize(base64decode($message)) without an allowedclasses allowlist, without authentication, and without any integrity check. The decoded value is then passed to displayLog(..., array $record) which assumes (without validating) that the result is an array. Any host that can reach TCP port 9911 on a machine running server:log can therefore submit attacker-chosen serialized PHP payloads. The minimum impact is an unauthenticated denial of service (sending a non-array, e.g. serialize(new stdClass()), crashes the listener with a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m7v2-7gxm-vc2v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45077

Advisory: Symfony has Unauthenticated PHP Object Deserialization in MonologBridge server:log Listener
IDs: CVE-2026-45077, GHSA-m7v2-7gxm-vc2v
Record: https://patchnext.com/advisories/cve-2026-45077 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 8.0.12, 7.4.12, 6.4.40, 5.4.52; symfony/monolog-bridge 8.0.12, 7.4.12, 6.4.40, 5.4.52. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected < 5.4.52; >= 6.0.0, < 6.4.40; >= 7.0.0, < 7.4.12; >= 8.0.0, < 8.0.12; fixed in 8.0.12, 7.4.12, 6.4.40, 5.4.52
- Packagist symfony/monolog-bridge: affected < 5.4.52; >= 6.0.0, < 6.4.40; >= 7.0.0, < 7.4.12; >= 8.0.0, < 8.0.12; fixed in 8.0.12, 7.4.12, 6.4.40, 5.4.52

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/monolog-bridge: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/monolog-bridge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m7v2-7gxm-vc2v (GitHub-reviewed advisory GHSA-m7v2-7gxm-vc2v lists affected ranges: Packagist symfony/monolog-bridge >=0 =6.0.0 =7.0.0 =8.0.0 =0 =6.0.0 =7.0.0 =8.0.0 <8.0.12)

Commands are suggestions: review each one before running it.

Loading voting…