Symfony Vulnerable to SQL Injection in PdoAdapter::doClear() via Unsanitized $prefix
CVE-2026-45073GHSA-6qh9-h6wf-jgqc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 8.0.12, 7.4.12, 6.4.40, 5.4.52; symfony/cache 8.0.12, 7.4.12, 6.4.40, 5.4.52), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- < 5.4.52>= 6.0.0, < 6.4.40>= 7.0.0, < 7.4.12>= 8.0.0, < 8.0.12
- Fixed in
- 8.0.12, 7.4.12, 6.4.40, 5.4.52
Packagist symfony/cache
- Affected
- < 5.4.52>= 6.0.0, < 6.4.40>= 7.0.0, < 7.4.12>= 8.0.0, < 8.0.12
- Fixed in
- 8.0.12, 7.4.12, 6.4.40, 5.4.52
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6qh9-h6wf-jgqc lists affected ranges: Packagist symfony/cache >=0 =6.0.0 =7.0.0 =8.0.0 =0 =6.0.0 =7.0.0 =8.0.0 <8.0.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-45073: 0.46% estimated exploitation activity in the next 30 days; percentile 39.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description Symfony\Component\Cache\Adapter\PdoAdapter is the PDO-backed cache adapter. Its clear($prefix) method (inherited from AbstractAdapterTrait) is documented to delete cache items whose key starts with $prefix. In the non-versioning code path, the caller-supplied $prefix is concatenated into $namespace = $this-namespace.$prefix and passed to PdoAdapter::doClear(), which builds: The value is interpolated directly into the SQL text and executed with PDO::exec(): $namespace is not bound. A caller able to influence $prefix can break out of the literal and inject SQL, expanding deletion scope from the intended prefix to arbitrary rows, or otherwise reshape query semantics. Most applications don't expose clear($prefix) to untrusted input directly, but the contract of the method is to safely accept any prefix string, so the lack of escaping is a defect of the adapter itself. Resolution AbstractAdapterTrait::clear() now rejects any $prefix containing characters outside…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6qh9-h6wf-jgqc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45073 Advisory: Symfony Vulnerable to SQL Injection in PdoAdapter::doClear() via Unsanitized $prefix IDs: CVE-2026-45073, GHSA-6qh9-h6wf-jgqc Record: https://patchnext.com/advisories/cve-2026-45073 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 8.0.12, 7.4.12, 6.4.40, 5.4.52; symfony/cache 8.0.12, 7.4.12, 6.4.40, 5.4.52. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected < 5.4.52; >= 6.0.0, < 6.4.40; >= 7.0.0, < 7.4.12; >= 8.0.0, < 8.0.12; fixed in 8.0.12, 7.4.12, 6.4.40, 5.4.52 - Packagist symfony/cache: affected < 5.4.52; >= 6.0.0, < 6.4.40; >= 7.0.0, < 7.4.12; >= 8.0.0, < 8.0.12; fixed in 8.0.12, 7.4.12, 6.4.40, 5.4.52 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/cache: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/cache. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6qh9-h6wf-jgqc (GitHub-reviewed advisory GHSA-6qh9-h6wf-jgqc lists affected ranges: Packagist symfony/cache >=0 =6.0.0 =7.0.0 =8.0.0 =0 =6.0.0 =7.0.0 =8.0.0 <8.0.12) Commands are suggestions: review each one before running it.
Loading voting…