Symfony's OidcTokenHandler Accepts JWTs Missing aud/iss/exp Claims
CVE-2026-45069GHSA-29fc-p6c4-24cg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 8.0.12, 7.4.12, 6.4.40; symfony/security-http 8.0.12, 7.4.12, 6.4.40), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- >= 6.3.0, < 6.4.40>= 7.4.0, < 7.4.12>= 8.0.0, < 8.0.12
- Fixed in
- 8.0.12, 7.4.12, 6.4.40
Packagist symfony/security-http
- Affected
- >= 6.3.0, < 6.4.40>= 7.4.0, < 7.4.12>= 8.0.0, < 8.0.12
- Fixed in
- 8.0.12, 7.4.12, 6.4.40
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-29fc-p6c4-24cg lists affected ranges: Packagist symfony/security-http >=6.3.0 =7.4.0 =8.0.0 =6.3.0 =7.4.0 =8.0.0 <8.0.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-45069: 0.26% estimated exploitation activity in the next 30 days; percentile 17.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description OidcTokenHandler is Symfony's built-in access-token handler for OpenID Connect: it validates a bearer JWT and returns the authenticated user identity. It delegates claim validation to the web-token/jwt-checker library's ClaimCheckerManager. OidcTokenHandler::verifyClaims() registers audience (aud), issuer (iss), and expiry (exp) checkers, but never passes the $mandatoryClaims argument to ClaimCheckerManager::check(). That method only validates claims that are present in the token: a checker for an absent claim is silently skipped. A validly-signed JWT that simply omits aud, iss, and exp therefore passes verification. Resolution The OidcTokenHandler now calls the ClaimCheckerManager with the list of mandatory claims so that tokens missing aud, iss, or exp are rejected. The patch for this issue is available here for branch 6.4. Credits Symfony would like to thank Claude Mythos Preview (via Project Glasswing) for reporting the issue and providing the fix.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-29fc-p6c4-24cg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45069 Advisory: Symfony's OidcTokenHandler Accepts JWTs Missing aud/iss/exp Claims IDs: CVE-2026-45069, GHSA-29fc-p6c4-24cg Record: https://patchnext.com/advisories/cve-2026-45069 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 8.0.12, 7.4.12, 6.4.40; symfony/security-http 8.0.12, 7.4.12, 6.4.40. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected >= 6.3.0, < 6.4.40; >= 7.4.0, < 7.4.12; >= 8.0.0, < 8.0.12; fixed in 8.0.12, 7.4.12, 6.4.40 - Packagist symfony/security-http: affected >= 6.3.0, < 6.4.40; >= 7.4.0, < 7.4.12; >= 8.0.0, < 8.0.12; fixed in 8.0.12, 7.4.12, 6.4.40 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/security-http: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/security-http. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-29fc-p6c4-24cg (GitHub-reviewed advisory GHSA-29fc-p6c4-24cg lists affected ranges: Packagist symfony/security-http >=6.3.0 =7.4.0 =8.0.0 =6.3.0 =7.4.0 =8.0.0 <8.0.12) Commands are suggestions: review each one before running it.
Loading voting…