Symfony has a UrlGenerator Route-Requirement Bypass via Unanchored Regex Alternation → Off-Site //host URL Injection
CVE-2026-45065GHSA-72xp-p242-47p9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 8.0.12, 7.4.12, 6.4.40, 5.4.52; symfony/routing 8.0.12, 7.4.12, 6.4.40, 5.4.52), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- < 5.4.52>= 6.0.0, < 6.4.40>= 7.0.0, < 7.4.12>= 8.0.0, < 8.0.12
- Fixed in
- 8.0.12, 7.4.12, 6.4.40, 5.4.52
Packagist symfony/routing
- Affected
- < 5.4.52>= 6.0.0, < 6.4.40>= 7.0.0, < 7.4.12>= 8.0.0, < 8.0.12
- Fixed in
- 8.0.12, 7.4.12, 6.4.40, 5.4.52
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-72xp-p242-47p9 lists affected ranges: Packagist symfony/routing >=0 =6.0.0 =7.0.0 =8.0.0 =0 =6.0.0 =7.0.0 =8.0.0 <8.0.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-45065: 0.35% estimated exploitation activity in the next 30 days; percentile 28.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description Symfony routes can declare a requirements regex per path parameter, e.g. a route /{locale}/blog with requirements: { locale: 'en|fr|de' }. The Twig path() / url() helpers (backed by UrlGenerator) validate supplied parameter values against that regex before building the URL. UrlGenerator constructs the validation pattern as '#^'.$req.'$#', where $req is the raw requirement string. For a requirement expressed as an alternation, e.g. locale: 'ar|bg|...|vi|...|zhCN' (very common), ^ and $ anchor only the first and last alternatives, so any middle alternative matches as an unanchored substring. A value like /evil.com satisfies the requirement (because it contains vi), and the generated path becomes //evil.com/...: a protocol-relative URL the browser navigates off-site. Resolution The UrlGenerator class now wraps the requirement in a non-capturing group so the ^ and $ anchors apply to the whole alternation. The patch for this issue is available here for branch 5.4. Credits…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-72xp-p242-47p9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45065 Advisory: Symfony has a UrlGenerator Route-Requirement Bypass via Unanchored Regex Alternation → Off-Site //host URL Injection IDs: CVE-2026-45065, GHSA-72xp-p242-47p9 Record: https://patchnext.com/advisories/cve-2026-45065 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 8.0.12, 7.4.12, 6.4.40, 5.4.52; symfony/routing 8.0.12, 7.4.12, 6.4.40, 5.4.52. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected < 5.4.52; >= 6.0.0, < 6.4.40; >= 7.0.0, < 7.4.12; >= 8.0.0, < 8.0.12; fixed in 8.0.12, 7.4.12, 6.4.40, 5.4.52 - Packagist symfony/routing: affected < 5.4.52; >= 6.0.0, < 6.4.40; >= 7.0.0, < 7.4.12; >= 8.0.0, < 8.0.12; fixed in 8.0.12, 7.4.12, 6.4.40, 5.4.52 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/routing: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/routing. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-72xp-p242-47p9 (GitHub-reviewed advisory GHSA-72xp-p242-47p9 lists affected ranges: Packagist symfony/routing >=0 =6.0.0 =7.0.0 =8.0.0 =0 =6.0.0 =7.0.0 =8.0.0 <8.0.12) Commands are suggestions: review each one before running it.
Loading voting…