Skip to content

← Actionable
High, CVSS 8.7

Symfony Vulnerable to Identity Spoofing via Unanchored DN Regex in X509Authenticator

CVE-2026-45063GHSA-ph86-p8f6-f9r2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 8.0.12, 7.4.12, 6.4.40, 5.4.52; symfony/security-http 8.0.12, 7.4.12, 6.4.40, 5.4.52), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    < 5.4.52>= 6.0.0-BETA1, < 6.4.40>= 7.0.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12
    Fixed in
    8.0.12, 7.4.12, 6.4.40, 5.4.52
  • Packagist symfony/security-http

    Affected
    < 5.4.52>= 6.0.0-BETA1, < 6.4.40>= 7.0.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12
    Fixed in
    8.0.12, 7.4.12, 6.4.40, 5.4.52

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-ph86-p8f6-f9r2 lists affected ranges: Packagist symfony/security-http >=0 =6.0.0-BETA1 =7.0.0-BETA1 =8.0.0-BETA1 =0 =6.0.0-BETA1 =7.0.0-BETA1 =8.0.0-BETA1 <8.0.12

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-45063: 0.37% estimated exploitation activity in the next 30 days; percentile 30.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description X509Authenticator implements client-certificate (mTLS) authentication: the web server validates the client's certificate against a trusted CA, then passes the certificate's Subject DN (Distinguished Name: a string like CN=Alice,O=Example,emailAddress=alice@example.com) to Symfony via $SERVER['SSLCLIENTSDN']. Symfony extracts the user identifier from that string. The extraction uses an unanchored regex that matches emailAddress= anywhere in the DN string: including inside the value of a different RDN (Relative Distinguished Name: one key=value component of the DN), such as CN. An attacker who can obtain a certificate from a trusted CA with a free-text CN can smuggle emailAddress=victim@target inside the CN value and be authenticated as the victim. Resolution The X509Authenticator now uses a regex that anchors the match to an RDN boundary (start of string, or following a , / / separator). The patch for this issue is available here for branch 5.4. Credits Symfony would like…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-ph86-p8f6-f9r2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45063

Advisory: Symfony Vulnerable to Identity Spoofing via Unanchored DN Regex in X509Authenticator
IDs: CVE-2026-45063, GHSA-ph86-p8f6-f9r2
Record: https://patchnext.com/advisories/cve-2026-45063 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 8.0.12, 7.4.12, 6.4.40, 5.4.52; symfony/security-http 8.0.12, 7.4.12, 6.4.40, 5.4.52. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected < 5.4.52; >= 6.0.0-BETA1, < 6.4.40; >= 7.0.0-BETA1, < 7.4.12; >= 8.0.0-BETA1, < 8.0.12; fixed in 8.0.12, 7.4.12, 6.4.40, 5.4.52
- Packagist symfony/security-http: affected < 5.4.52; >= 6.0.0-BETA1, < 6.4.40; >= 7.0.0-BETA1, < 7.4.12; >= 8.0.0-BETA1, < 8.0.12; fixed in 8.0.12, 7.4.12, 6.4.40, 5.4.52

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/security-http: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/security-http.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ph86-p8f6-f9r2 (GitHub-reviewed advisory GHSA-ph86-p8f6-f9r2 lists affected ranges: Packagist symfony/security-http >=0 =6.0.0-BETA1 =7.0.0-BETA1 =8.0.0-BETA1 =0 =6.0.0-BETA1 =7.0.0-BETA1 =8.0.0-BETA1 <8.0.12)

Commands are suggestions: review each one before running it.

Loading voting…