Budibase vulnerable to SSRF via trivial .tar.gz substring bypass in Plugin URL upload (/api/plugin)
CVE-2026-45061GHSA-xh5j-727m-w6gg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (budibase 3.35.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm budibase
- Affected
- <= 3.34.11
- Fixed in
- 3.35.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xh5j-727m-w6gg lists affected ranges: npm budibase >=0 <3.35.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xh5j-727m-w6gg lists affected ranges: npm budibase >=0 <=3.34.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-45061: 0.26% estimated exploitation activity in the next 30 days; percentile 18.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
1. Summary | Field | Value | |-------|-------| | Title | SSRF via trivial .tar.gz substring bypass in Plugin URL upload | | Product | Budibase (Self-Hosted) | | Version | ≤ 3.34.11 (latest stable as of 2026-03-30) | | Component | packages/server/src/api/controllers/plugin/url.ts | | Vulnerability Type | CWE-918: Server-Side Request Forgery (SSRF), CWE-184: Incomplete List of Disallowed Inputs | | Severity | High (chained) / Medium (standalone) | | CVSS 3.1 Score (chained) | 7.7 — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N | | CVSS 3.1 Score (standalone) | 5.4 — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N | | Attack Vector | Network | | Privileges Required | Low (Global Builder role) | | User Interaction | None | | Affected Deployments | All Budibase instances with plugin loading enabled (default) | --- 2. Description The Plugin URL upload endpoint (POST /api/plugin) validates the submitted URL with a single substring check: url.includes(".tar.gz"). Any URL containing .tar.gz…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xh5j-727m-w6gg
- Revision 1 · created ·
Published from osv record GHSA-xh5j-727m-w6gg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45061 Advisory: Budibase vulnerable to SSRF via trivial `.tar.gz` substring bypass in Plugin URL upload (`/api/plugin`) IDs: CVE-2026-45061, GHSA-xh5j-727m-w6gg Record: https://patchnext.com/advisories/cve-2026-45061 (revision 2, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: budibase 3.35.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm budibase: affected <= 3.34.11; fixed in 3.35.10 ## Suggested inspection (read-only) - `npm ls budibase --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on budibase. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xh5j-727m-w6gg (OSV record GHSA-xh5j-727m-w6gg lists affected ranges: npm budibase >=0 <3.35.10 (fixed)) - Verified: https://github.com/advisories/GHSA-xh5j-727m-w6gg (GitHub-reviewed advisory GHSA-xh5j-727m-w6gg lists affected ranges: npm budibase >=0 <=3.34.11) Commands are suggestions: review each one before running it.
Loading voting…