Skip to content

← Actionable
High, CVSS 8.3amended

OpenAM Unauthenticated Session Hijacking via Information Exposure in CDCServlet

CVE-2026-45049GHSA-r9pv-5rpp-vm8g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openidentityplatform.openam:openam-federation 16.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-45049: 0.33% estimated exploitation activity in the next 30 days; percentile 26.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Description An Information Exposure Through Sent Data (CWE-201) issue in OpenAM's Cross-Domain Single Sign-On (CDSSO) servlet allows a logged-in user's raw OpenAM session token to be POSTed to an attacker-controlled URL. This impacts OpenAM Community Edition through version 16.0.6. This issue was patched in version 16.1.1. An attacker who can induce a logged-in victim to visit a crafted URL may receive the victim's session credential, which could enable session hijacking.

Impact OpenAM deployments through version 16.0.6 that have CDSSO enabled are potentially affected. The CDSSO component is commonly enabled in multi-domain deployments. Exploitation requires user interaction — an authenticated user must be induced to visit an attacker-crafted URL — and is further gated on a non-default configuration being absent.

Patch This has been patched in OpenAM Community Edition version 16.1.1. Users are encouraged to update to the latest release.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-r9pv-5rpp-vm8g

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-r9pv-5rpp-vm8g

  3. Revision 1 · created ·

    Published from ghsa record GHSA-r9pv-5rpp-vm8g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45049

Advisory: OpenAM Unauthenticated Session Hijacking via Information Exposure in CDCServlet
IDs: CVE-2026-45049, GHSA-r9pv-5rpp-vm8g
Record: https://patchnext.com/advisories/cve-2026-45049 (revision 3, source checked 29 Oct 2026, 06:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.openidentityplatform.openam:openam-federation 16.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.openidentityplatform.openam:openam-federation: affected < 16.1.1; fixed in 16.1.1

## Suggested inspection (read-only)
- Maven org.openidentityplatform.openam:openam-federation: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.openidentityplatform.openam:openam-federation.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r9pv-5rpp-vm8g (GitHub-reviewed advisory GHSA-r9pv-5rpp-vm8g lists affected ranges: Maven org.openidentityplatform.openam:openam-federation >=0 <=16.0.6)
- Verified: https://osv.dev/vulnerability/GHSA-r9pv-5rpp-vm8g (OSV record GHSA-r9pv-5rpp-vm8g lists affected ranges: Maven org.openidentityplatform.openam:openam-federation >=0 <16.1.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…