Chainlist has SSRF via MCP SSE and streamable-http transports that allows unauthenticated internal network access
CVE-2026-45019GHSA-hvfh-5mj3-5f3j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (chainlit 2.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI chainlit
- Affected
- >= 2.4.0rc0, < 2.12.0
- Fixed in
- 2.12.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hvfh-5mj3-5f3j lists affected ranges: PyPI chainlit >=2.4.0rc0 <=2.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hvfh-5mj3-5f3j lists affected ranges: PyPI chainlit >=2.4.0rc0 <2.12.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-3811 lists affected ranges: PyPI chainlit >=2.4.0rc0 <2.12.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-120492: 0.22% estimated exploitation activity in the next 30 days; percentile 12.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
- CVE-2026-45019: 0.43% estimated exploitation activity in the next 30 days; percentile 37.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Am I affected? Only if your deployment sets `features.mcp.enabled = true` in `.chainlit/config.toml`. MCP has been disabled by default since v2.7.0, so most Chainlit deployments are not affected. No authentication is required: `/mcp` is reachable by any client that can open a session.
Summary When MCP is enabled (`features.mcp.enabled = true`), the `POST /mcp` endpoint for `sse` and `streamable-http` transports accepts a user-controlled `url` and optional `headers` dictionary without any validation. An unauthenticated attacker can force the Chainlit server to make outbound HTTP requests to arbitrary URLs — including internal network services and cloud metadata endpoints — with attacker-controlled HTTP headers such as `Authorization` and `Cookie`.
Affected / patched versions | | | |---|---| | CVE | CVE-2026-45019 | | Affected — URL-based SSRF | `>=2.4.0rc0, =2.6.4, Breaking change. 2.12.0 changes how MCP servers are configured. If `.chainlit/config.toml` still uses…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record PYSEC-2026-3811
- Revision 2 · amended ·
Amended from osv record GHSA-hvfh-5mj3-5f3j
- Revision 1 · created ·
Published from ghsa record GHSA-hvfh-5mj3-5f3j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45019 Advisory: Chainlist has SSRF via MCP SSE and streamable-http transports that allows unauthenticated internal network access IDs: CVE-2026-45019, GHSA-hvfh-5mj3-5f3j Record: https://patchnext.com/advisories/cve-2026-45019 (revision 3, source checked 3 Nov 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: chainlit 2.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI chainlit: affected >= 2.4.0rc0, < 2.12.0; fixed in 2.12.0 ## Suggested inspection (read-only) - `python -m pip show chainlit`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on chainlit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hvfh-5mj3-5f3j (GitHub-reviewed advisory GHSA-hvfh-5mj3-5f3j lists affected ranges: PyPI chainlit >=2.4.0rc0 <=2.11.1) - Verified: https://osv.dev/vulnerability/GHSA-hvfh-5mj3-5f3j (OSV record GHSA-hvfh-5mj3-5f3j lists affected ranges: PyPI chainlit >=2.4.0rc0 <2.12.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-3811 (OSV record PYSEC-2026-3811 lists affected ranges: PyPI chainlit >=2.4.0rc0 <2.12.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…