Chainlit has command injection via MCP stdio transport that allows unauthenticated remote code execution
CVE-2026-45018GHSA-w3fx-mc44-mf6j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (chainlit 2.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI chainlit
- Affected
- >= 2.4.0rc0, <= 2.11.1
- Fixed in
- 2.12.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w3fx-mc44-mf6j lists affected ranges: PyPI chainlit >=2.4.0rc0 <=2.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w3fx-mc44-mf6j lists affected ranges: PyPI chainlit >=2.4.0rc0 <2.12.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-45018: 1.09% estimated exploitation activity in the next 30 days; percentile 65.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Am I affected? Only if your deployment sets features.mcp.enabled = true in .chainlit/config.toml. MCP has been disabled by default since v2.7.0, so most Chainlit deployments are not affected. No authentication is required: /mcp is reachable by any client that can open a session. Summary When MCP is enabled (features.mcp.enabled = true), the POST /mcp endpoint for stdio transport accepts a user-controlled fullCommand string. The validatemcpcommand() function checks the executable name against a configurable allowlist but does not inspect or restrict the arguments. An attacker can pass npx -y -c 'ARBITRARY COMMAND' to execute arbitrary shell commands on the server with the privileges of the Chainlit process. Affected / patched versions | | | |---|---| | CVE | CVE-2026-45018 | | Affected | =2.4.0rc0, <2.12.0 with features.mcp.enabled = true (introduced in PR #1977, the change that added MCP support) | | Patched | 2.12.0 (releasing 2026-08-25) | Details validatemcpcommand() in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w3fx-mc44-mf6j
- Revision 2 · amended ·
Amended from osv record GHSA-w3fx-mc44-mf6j
- Revision 1 · created ·
Published from ghsa record GHSA-w3fx-mc44-mf6j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45018 Advisory: Chainlit has command injection via MCP stdio transport that allows unauthenticated remote code execution IDs: CVE-2026-45018, GHSA-w3fx-mc44-mf6j Record: https://patchnext.com/advisories/cve-2026-45018 (revision 3, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: chainlit 2.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI chainlit: affected >= 2.4.0rc0, <= 2.11.1; fixed in 2.12.0 ## Suggested inspection (read-only) - `python -m pip show chainlit`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on chainlit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w3fx-mc44-mf6j (GitHub-reviewed advisory GHSA-w3fx-mc44-mf6j lists affected ranges: PyPI chainlit >=2.4.0rc0 <=2.11.1) - Verified: https://osv.dev/vulnerability/GHSA-w3fx-mc44-mf6j (OSV record GHSA-w3fx-mc44-mf6j lists affected ranges: PyPI chainlit >=2.4.0rc0 <2.12.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…