Skip to content

← Actionable
Critical, CVSS 9.1

phpMyFAQ enables unauthenticated 2FA brute-force attack via /admin/check acceptance of arbitrary user-id

CVE-2026-45010GHSA-9pq7-mfwh-xx2j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 4.1.2; thorsten/phpmyfaq 4.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-45010: 0.43% estimated exploitation activity in the next 30 days; percentile 37.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The /admin/check endpoint in AuthenticationController implements SkipsAuthenticationCheck, making it reachable without any prior authentication. An anonymous attacker (Bob) can POST arbitrary user-id and token values to brute-force any user's 6-digit TOTP code. No rate limiting exists. The 10^6 keyspace is exhaustible in minutes. Reachability confirmed against a default install: unauthenticated POST /admin/check with a user-id body field returns HTTP 302 to /admin/token?user-id=<value, echoing the attacker-supplied user id without any binding to a prior password-phase authentication. Details File: phpmyfaq/src/phpMyFAQ/Controller/Administration/AuthenticationController.php, lines 35-36 and 201-228. The controller class declaration: The SkipsAuthenticationCheck interface (phpmyfaq/src/phpMyFAQ/Controller/Administration/SkipsAuthenticationCheck.php) is a marker interface that tells the ControllerContainerListener to skip authentication enforcement. Every route in this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9pq7-mfwh-xx2j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45010

Advisory: phpMyFAQ enables unauthenticated 2FA brute-force attack via /admin/check acceptance of arbitrary user-id
IDs: CVE-2026-45010, GHSA-9pq7-mfwh-xx2j
Record: https://patchnext.com/advisories/cve-2026-45010 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 4.1.2; thorsten/phpmyfaq 4.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmyfaq/phpmyfaq: affected <= 4.1.1; fixed in 4.1.2
- Packagist thorsten/phpmyfaq: affected <= 4.1.1; fixed in 4.1.2

## Suggested inspection (read-only)
- Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager.
- Packagist thorsten/phpmyfaq: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmyfaq/phpmyfaq, thorsten/phpmyfaq.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9pq7-mfwh-xx2j (GitHub-reviewed advisory GHSA-9pq7-mfwh-xx2j lists affected ranges: Packagist thorsten/phpmyfaq >=0 =0 <=4.1.1)

Commands are suggestions: review each one before running it.

Loading voting…