Skip to content

← Actionable
Medium, CVSS 4.3

phpMyFAQ: Ordinary Authenticated User Can Access Admin-Only API Endpoints Due to Insufficient Authorization Check in phpMyFAQ

CVE-2026-45009GHSA-jrc5-w569-h7h5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 4.1.2; thorsten/phpmyfaq 4.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-45009: 0.21% estimated exploitation activity in the next 30 days; percentile 11.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A review of phpMyFAQ-main uncovered an authorization issue in the admin-api routes. Several backend endpoints only check whether the caller is logged in. They do not verify that the caller actually has backend or administrative privileges. As a result, a normal frontend user can access API endpoints that are clearly intended for administrative use. During local reproduction, a regular user account was able to request /admin/api/index.php/dashboard/versions and receive a successful response from the backend management API. This issue does not appear to give direct write access in the affected paths that were confirmed, so it should be treated as a backend information disclosure and privilege boundary failure rather than full admin compromise. Details The access control split is visible in the controller base class: The problem is that several Administration\Api controllers use the weaker check even though the routes sit under the backend API namespace. For example,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jrc5-w569-h7h5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45009

Advisory: phpMyFAQ: Ordinary Authenticated User Can Access Admin-Only API Endpoints Due to Insufficient Authorization Check in phpMyFAQ
IDs: CVE-2026-45009, GHSA-jrc5-w569-h7h5
Record: https://patchnext.com/advisories/cve-2026-45009 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 4.1.2; thorsten/phpmyfaq 4.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmyfaq/phpmyfaq: affected >= 4.1.1, <= 4.1.1; fixed in 4.1.2
- Packagist thorsten/phpmyfaq: affected >= 4.1.1, <= 4.1.1; fixed in 4.1.2

## Suggested inspection (read-only)
- Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager.
- Packagist thorsten/phpmyfaq: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmyfaq/phpmyfaq, thorsten/phpmyfaq.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jrc5-w569-h7h5 (GitHub-reviewed advisory GHSA-jrc5-w569-h7h5 lists affected ranges: Packagist thorsten/phpmyfaq >=4.1.1 =4.1.1 <=4.1.1)

Commands are suggestions: review each one before running it.

Loading voting…